V5 download cable no longer downloading code

The v5 download has stopped working. In this particular case the cable was hooked up to my computer which displayed a voltage overload warning while running my auton. After attempting to plug the cable back into the brain it is not able to download code, strangely the cable can still charge the controller. Has anyone else experience a cable issues like this? Is there anyway to fix it?

Does the IDE still say “brain connected” after plugging?

Have you simply tried a different cable?

We have had a few cable connections issues which have been solved by:
-Wiggling the cable in the brain until it works
-Using a different cable
-Blowing into the end of the cable then plugging it in (May harm cable/brain in the long term, idk)

1 Like

1 and 3 sound extra sketch lmao

1 Like

This may not be what it is, but I’ve had prongs in the brain go out of place. Wiggling them back really does help. But first you should try a new download cord.

1 Like

The computer detects the cable is connected to something, however the brain connect pop up never come up

Probably not your situation, but a few times this happened we restarted the computer and it started to work again. But I’m sure you already tried that…

I am having the same problem with ALL my V5s - brand new this year! It sometimes connects with the cable, but the download is “greyed out” and doesn’t connect. This is so frustrating - my students are getting frustrated too.