V5 motor led flashing red

Hello our robot has a motor that flashes red, this occurs in any of the motor ports. It worked less then 10 minutes ago but then it stopped working completely. It controlled our hand which rotates the waffles. It was set to rotate 180 degrees when the button was pressed, then we tried to switch it to just rotate but it wouldn’t even do that. The light pulses very slowly for a long time then after some messing around we got it to pulse fast like really fast
IMG_0355.JPG
IMG_0354.JPG
IMG_0356.JPG

We had this same problem and eventually got it to work but it took some time. Here are a few things that we did.

  1. Try re-crimping your V5 cables very hard, even the ones that were from Vex.
  2. It may be a connection issue where the plastic fin doesn’t hold it in the socket strong enough. Try putting some electrical tape on the motor to hold the wire in place.
  3. Check to see if firmware needs to be updated.

I hope this helps you solve your problem.

Sadly we tried many cables that worked. After our coach asked around we determined the motor is dead.