V5 Motors Not Spinning

I have at least 6 motors that won’t move. I can manually spin them like a regular motor. And when I plug them into the brain the red light on the motor flashes quickly every 2-ish seconds. They seem like normal motors, but when I plug them in, they don’t work. Other motors work on the same port with the same wire. Are the motors shot? If so, what can I do (if anything)? If not, how can I fix them? Thanks!

I apologize if this has already been answered, but I looked and couldn’t find any solutions.

Have you tried with other wires? It’s pretty likely that the motor is the troublemaker here but it’s hard to confirm it entirely until you test multiple ports and wires. From personal experience, I can say it is possible that faulty wires will work with one electronic but not another. Usually, if a motor is dead, it’s unlikely you will get a flashing red light, you normally get no illumination at all, which is why I still have hope that the motor is alive.

If you have tried multiple wires and port combinations and the motor still does not respond, I believe your next step would be to email support@vex.com about it.

8 Likes

I tried several other ports and wires on each motor, and they still do the same flashing with no movement. I’ll email them, thanks.

1 Like

in my experience an unresponsive flashing motor port on an otherwise working cable and brain port means the motor (possibly motor port?) is fried. Has been a lot less common than brain ports frying in my experience, but still happens relatively frequently in static-prone environments.

7 Likes

if i were you i would try a different cable or brain if you can

I have…

I tried other brains too.

1 Like

maybe check if the motor cartridges are in right and not stripped and double check your code

I have tried them with and without cartridges, and it can’t be the code because the same motors on the same port with the same code work fine.

then i would suspect that your motors are just dead because as the first reply said the blinking light means somethings wrong

That means there is no communication with the V5 brain and the motor is running in the bootloader code.

most likely.

There can be two causes for this.

The pins of the smartport on the motor may be damaged, check to see if any are bent and not making contact with the cable.

The internal RS485 driver may be damaged, there is no competition legal way to repair this part.

9 Likes

The pins look fine to me.

Is there any way to repair the RS485 driver, maybe not legally? It would be a huge help if we could get the motors working for practice, and then we could switch out the motors for competition.

2 Likes

obviously replace the part but, again, not competition legal and I’m not providing any instructions.

haha, yea, right.

10 Likes

Does repairing the RS485 driver affect motor performance at all? Or would said motor act identically to a normal motor.

It’s not possible to anticipate every manner in which a team may modify a motor to gain an advantage, so the GDC has implemented a blanket ban on any modification. Unfortunately this has the side effect of preventing teams from repairing damage caused due to shortcomings in the motor’s design.

10 Likes

I understand the intent of the rule. However, my question is whether or not the modifications described above would alter the motor’s performance.

If the replacement part is identical, obviously there would be no change to the motor’s performance. However, because it is practically impossible to determine the difference between a modification which has not altered a motor’s performance and one that has, such a modification is illegal.

8 Likes

I can’t be the only one who likes to keep old robots together and functional.

1 Like

I mean, what would you think ?

The repair is about as easy as it gets for part replacement assuming you have the tools and skill to work on surface mount components. However, your primary issue would be this, when I check for the part on common sites, this is what you will find.

lead_time

12 Likes

Not much worse than lots of vex parts right now

6 Likes