V5 Vex Battery Not Working

Hi all, I am a student at a high school using the PLTW program and vex equipment for our engineering class. We recently purchased new vex equipment last week and just began a project, however after charging the batteries we noticed one V5 battery we received does not work.

I do not believe holding charge is the issue, due to it being new and because the LED lights on the battery are on very bright, but are a color combination not documented on the Vex battery trouble shooting website.

After following the instructions on another forum post I reset the battery using a paperclip and pressing on the small hole on the top multiple times and then charging it for an hour however there has been no change.

Is there anything else we can do to try to fix this newly bought battery?

What are they showing ?

Generally try and avoid ever doing that, last resort sort of thing.

Will the battery power the brain (even with charger attached) ? If so run battery medic and see what that shows.


I see, but no battery does not power brain

Usually when there is a mix of green and red lights, we just try to update the batteries and that usually works. (I have never done it because I just give it to one of my sister teams because I don’t know how to do it). I think what you are supposed to do it plug it into the wall and your brain at the same time and something will appear on your brain screen (I think). You can try and see if this works.

It is exactly this, its a weird mix of red and green, but on of the combinations listed on the VEX battery troubleshooting page. I tried your advice today in class, plugging in the battery and connecting it to the brain at the same time but that did not work.

this usually means that the battary might need to be manually reset, we have this happen all the time at my robotics club, you need a small stick to poke the hole on the top of the battery and that should fix your issue.

again, I need to discourage teams from doing this. Using the reset button will cause the battery to lose certain history about charge state, displayed capacity will be incorrect until the battery has been fully charged and discharged.

perhaps shoot a video so we can see exactly what the LED are doing. It feels like the battery is in bootload mode or has some other type of fatal error. If this is a brand new battery and the V5 will not update it, perhaps it’s time to just contact VEX support and arrange an RMA.


3 letters…


Got it, I already tried to reset the battery to factory settings, we’re not a vex team we use vex materials for our PLTW class so the history/data isn’t as important for us although I appreciate the warning!

I’ll get you a video/pic tomorrow, but the combination from my memory was I believe red, green, green, red. None were flashing and its not an error combination on vex battery troubleshooting page.

And yes these batteries are less than a week old. I contacted vex an an auto bot also told me to submit an RMA. Thank you all for the help!

Yea I did that a couple times, no change unfortunately