V5: Vision sensor isn't saving signatures

I started messing around with the Vision Sensors and it seems like it isn’t saving the signatures. I’m doing what I’ve seen others recommend (Freeze the screen, set the signature, unfreeze, unplug, download to the brain) and the moment I go back into the signature screens all my signatures have been cleared. At first, I noticed this because I’m using a code to align my bot to the X-centre of the largest object, but it merely kept spinning and spinning. I haven’t tried running the code using a colour that doesn’t exist in my room, nor have I tried simply running the code without any saved signatures. Here are some things that I think are noteworthy:

  1. I’m using Vex C++, not C++ pro. I don’t have access to the config file as such, though I have found a way to observe it while in Vex C++ (In case it isn’t clear, I am using VCS).
  2. When I go back into the signature screen, all my signatures except the first one is completely cleared. The first one still does not seem to exist, however, because it doesn’t display on the screen “SIG_1” where ever its colour should be.
  3. It will save the signature’s names. My first and second signatures are named “BLUECAP” and “REDCAP” respectively.

Am I doing something wrong? I’ve seen some people say they’ve had to do it multiple times to get it to save but I haven’t gotten it to save once.

Can you attach a .vex project that’s having issues.