V5 wireless VEXnet downloading with Robot Mesh Studio

Now use Robot Mesh Studio to wirelessly download programs to your V5 brain via VEXnet:

  • Tether your V5 Controller to your V5 brain and then setup a wireless VEXnet connection with a V5 Radio.
  • Connect your computer to the V5 Controller using the USB cable (USB connection is below the front of the controller)
  • Use the latest online version of Robot Mesh Studio at https://www.robotmesh.com/studio or use the latest version (2.0.1.2) of the Desktop edition or rmbuild from https://www.robotmesh.com/desktop and click Run/Download.

Other new features in this release!

  • V5 SD card support in Python and JavaScript for reading/writing binary and text, and for reading and displaying image files.
  • Auto-complete in the text editor for JavaScript programs

Notes:

  • Currently the following are not available wirelessly: writing back to the computer’s console (print/printf), Connected mode and Python/Blockly debugging. Stay tuned, these features will come soon!
  • Bluetooth download directly from your computer to the brain isn’t yet supported.
  • Robot Mesh Studio programming languages for V5 now use our innovative Robot Mesh Virtual Machine (VM) running on the V5 brain. This results in faster wireless downloads. The VM includes the runtimes for the Python and JavaScript languages, as well as the PNG image processing and “eyes” images used by all languages. C++ download times may take 10-60 seconds. The VM will download and update automatically. If you want to use wireless download, it may be worthwhile downloading first over USB so the VM is downloaded quickly.

May the radio-waves be with you.

4 Likes

Great addition for Robot Mesh Studio users! Well done!

2 Likes

Is there any reason NOT to use Robot Mesh? No. There isn’t.

Some examples of using the drawing functions for custom images: C++, Python, JavaScript.

@John_TYler Is it possible to have multiple files in a project in RMS? If so, how would one go about creating a multi-file project?

Yes and no. With the RMS interface online and in RM Desktop, it is not. However, if you want to use your own editor, RMBuild command line tool can take multiple C++ files. When you invoke rmbuild in the command line, you simply list all your .cpp files in the command: rmbuild v5 filetorpedoes.cpp fileone.cpp filetwo.cpp (plus any other options).

That being said, there is a bit of a trick you can use to both use the online/Desktop editor and not have to copy/paste the contents of your code to new files. If you use the Desktop client to make a local copy, the .cpp files show up in your \Documents\RobotMesh\ folder. You can even run rmbuild against them in that directory without having to move, copy, or rename them.

1 Like

Connected the controller to the PC USB. Controller is paired with the “brain”. Opened the Robotmesh studio (latest download- how do I find the version number?)

Before connect - I have to set the USB Controller port in options
Then after pressing connect I get error - Capture The firmware version shown here is incorrect as verified in vex studio. How can I make the wireless update work?

Make sure you are running version 2.0.1.2 of RMS Desktop. You can find the version number in the list of installed programs in Windows. In Win10, open the start menu, search for add or remove programs, open that, search for Robot Mesh Studio Desktop, then click on it. It should show the version number there beneath the program name.

image

Thanks - that works. I had 2.0.1.1, which has the download issue.
The download itself is slow but better than USB connecting cable in some instances

Hi, anything special that needs to be done with the online version? We connected the controller to the same USB port we use to download to the brain tether - it’s the only USB 2.0 port on our machine, USB 3 ports make the brain freeze all the time. We noticed Windows 10 do its driver thing and when everything seemed connected hit the Download button. The interface just sits with the words “Compiling” and nothing else happens. Then when we disconnect, the controller is either frozen and needs to be poked in the hole to wake up or the controller can’t start a program anymore (we navigate the menu as always and when we hit run nothing happens). We tried to free the Chrome cache with F5 and CTRL-F5, no fix.

You shouldn’t need to do anything special, no. I haven’t seen the USB 3 problem you are describing, either.

Would you mind hitting F12 when in Chrome to open its console and PM’ing me a screenshot of any errors that show up when you try to compile and download?

@John_TYler I updated RMBuild but I can’t download to the brain. It compiles without a problem and then just gets stuck on “Downloading” line indefinitely. I reverted to an older version of RMBuild and it downloads just fine. Any ideas?

It won’t download at all, either wirelessly or with a direct connection? What version of Windows are you using?

I first tried to download wireless, when that didn’t work I plugged it in and i got the same issue. I tried multiple times before reverting back to an older version of RMBuild, which worked just fine. I am running Windows 10 Home.

Do you have any other USB devices plugged in, or anything else that would be trying to talk to a VEX device? (VCS, RMS, the V5 updater, etc) Have you tried it on a different computer?

At the time nothing else was plugged into the computer, and the only other program running was Visual Studio Code. I am about to try a different computer.

Ok, I just figured it out. I had the regular Robot Mesh Studio on my desktop but not on my laptop. The new RMBuild worked on the desktop but not on the laptop. I downloaded RMStudio and RMBuild started working again on my laptop. (including wireless programming)

Hmm. RMbuild ought to be completely standalone, and not require the presence of any other Robot Mesh product. I just tried uninstalling RMS Desktop and RMC from my dev machine, and RMbuild worked fine without them. We will investigate further.