VCS V5 program downloading trouble

Ok back at it again with another programming issue!

We’ve been working on our autonomous to get ready for worlds, and I was about done before a disastrous issue struck us. We could not update our program anymore. We could comment out the autonomous out and it wouldn’t run anymore, but we couldn’t change the values or add any other steps to the actual autonomous. I tried powercycling the brain, restarting VCS, using another cable, copying the program to another slot on the brain, copying the file and putting it in another slot, and restarting the computer. All of the solutions I’ve seen on the Forums haven’t worked.

Any help would be greatly appreciated, thanks!

So, to specify, if you added new values/steps, the program would do the old thing, or just not download?

It would “download” without issue, but simply run the old program.

Then it probably has an error, VCS is not so good at reporting all errors. Send me the code if you want me to take a look.
(the .vex file)

In that case I would check your code and see if anything might be out of place. A missing bracket or parenthese could be messing up your code.

EDIT: Ninja’d by jpearman

Sure thing, I apologize for any coding sins you encounter in our code. (Im not supposed to be the programmer)