Velocity setting with controller

We are using the sample claw bot controller program which uses a standard tank drive in which the velocity is set by the joystick positions A and D. It appears everything was working ok, but when we have joysticks at max position/velocity the speed seems slower than the speed observed when running an autonomous code with velocity set to 100%. The speed when using the controller appears to be about 20% less than the speed observed when running code only.


Joystick calibration issue? Try printing the controller values to the IQ Brain screen so you can check you are getting to 100.

POST YER CODE (20 chars)

1 Like

I can’t remember where I saw it now, but I thought the motors defaulted to a setting that was less than 100%. If you want the drive motors to be capable of 100% speed, I believe you have to use the “set motor to velocity” block

the sample clawbot code includes some weird axis value divided by 2 for some reason, which would explain why it wouldn’t be going as fast as during a properly created autonomous. Just remove the ‘/2’ at the end of the motor controlling line and you’re good to go.


It’s not evident from the blocks that the velocity is being reduced. I assume you are seeing the text version?

That should work perfectly. So when you are using standard driver control it goes much faster?

Can you share the rest? I’m curious if something else is messing with it… The share button should make a nice PDF.

From the STEM Labs …
"VEX IQ Smart Motors can be programmed to spin or drive at many different velocities. If you have programmed your robot to drive or turn before, you probably did it with the default velocity. The default velocity is the velocity that the Smart Motors turn at automatically - if you don’t add any type of block for setting the velocity. The default velocity is 50% of the maximum velocity. The maximum velocity is 100%. "
STEM Lab Changing Velocity

1 Like

So how then do you override that setting using the blocks for the controller? Would a “set velocity” block be overturned by the controller A and D position = velocity blocks?

Have you tried what I suggested regarding printing your controller values to screen so you can be sure you are sending the value you think you are sending to the motors?

Based on that STEM Lab, I believe if you use a set velocity block it will correct your problem. I haven’t tried it yet.

I will try both of those suggestions and report back. I haven’t had time to play around and test it yet. Thank you for the suggestions so far.

Any update? I’m curious to know what happened

It’s fall break so we haven’t tested it yet