VEX 75 MHz Control System basics

Please don’t flame me for being lazy or stupid. I’ve looked everywhere for what I’m sure is 101 basics.
Inherited a pile of Vex gear and told go teach! Spent hours sorting gear!
Worked out how to upgrade software and get three Vex joysticks and Cortex receivers talking to each other.
But I also have two VEX 75 MHz Control System (no splitter box) and two controlers. I have a receiver connected and it has the correct crystals but I can’t get anything to work. Even tried with a robot tether. They seem to be seeing each other… but doing nothing due to previous use or programming in the past.
Is there a video somewhere on how to do this. What software to use, (currently using RobotC ) etc. i really need this working as the kids have got 5 basic robots made and only three transmitters. Nothing fancy. I just need control of 5 motors initially.
Yes I’ve read Control
I have no software disks for anything.
Yes I’ve tried resetting the radio and clearing programs. I’m missing something very basic.
I’m really back at point zero intellect on the VEX 75 MHz Control System learning curve.
Any help appreciated.

Ah this is easy. You’ve got the old PIC V5 microcontroller.

You’ll likely need to flash it with the default code, for that you’re going to need the old programming cable. This is the new one which I believe still works, but you may have one of the old ones laying around too.

Once you have the cable in hand, go here to find the software to upload the firmware and corresponding firmware to upload.

If memory serves right, plugging in the old joystick into the first slot and moving the sticks around should send commands to motor ports 1-4.

To download actual code (like custom code), you’ll need a current or older copy of EasyC or ROBOTC. You can always download a trial and test things out.

If that doesn’t help, post pictures of all the components you have plugged in. The motors, the joystick, the crystals, etc. If you have the telephone wire style tether, use that until something works just to eliminate variables.

Thanks for help.
No Go
did ifi loader controller verification (controller verification complete ) then tried to download default software and it comes back with unknown device (0)
I’ve tried it with both the new and old style serial adapters you’ve shown above.

And whilst digging around I found two upgrade kits which which obviously have been used. (Everything i got was dismantled and tossed in a box.) so I had a play with them.
I got them paired to the radio so they were definitely reading each other and showing green led’s but still no servo action. My trial period of RobotC is expired so will have to wait until work supplies money for software keys.


Oh wow ok.

I would recommend removing the upgrade kit from both the V5 PIC and the controllers for now.

As for the unknown device, I’m not sure.

@gasayers - “comes back with unknown device (0)”

You may be having a problem with Windows drivers and the USB Serial cable. There was an issue where people were using the development UID’s for the USB devices. About 3 years ago there was a change to the Windows drivers that disabled that ID.

If you did around on the VEX site they have older versions of the drivers that work on Win7 and 8.

You can also try to find someone with the new version of the orange programming cable.

Not quite accurate. The original programming cable used a USB to serial device from a company called Prolific. Due to its popularity it was cloned by other companies who had reversed engineered the design (of the USB/serial chip, not the cable), these parts ended up being used in many cables. Prolific was not happy that their IP had been pirated and updated their driver to detect the clone devices, cables using the clones subsequently stopped working.

I discussed some of this in a thread a couple of year ago.

Windows 10 has a habit of updating drivers automatically, we often have to tell customers to roll back the driver to the one that ROBOTC installs.

Hey while you may be stuck on software licenses for the ROBOT - C for Cortex, you can get a free version for the older PIC controllers from ROBOT C here
I use it for my old PIC on a older laptop to let students mess around. I’ve not used the RC control in a long time however so I can’t help there. I currently either use the PIC in standalone Autonomous or control it with a customer controller built from sparkfun products and use a pair of X-Bee radios for the comm link.

Good luck getting the funding for the Robot C code. I think it’s well worth the investment.

I recently bought a used Protobot with the PIC controller for my son. The robot works fine in autonomous mode and remote control mode. I downloaded a free version of Robot C V 3.xx, I believe from the previous site. We wrote some simple code that we now want to down load to the robot. The PC with RobotC V 3.xx has windows 8. I am considering buying the programming cable. Once I have the cable, do I really need to upgrade any firmware update on the PIC? What is the benefit of doing this if the PIC controller seems to work OK? This will be our first time downloading a program to this robot. I will search other threads to learn how to make this robot run with the new program, once we get here.