VEX ARM Cortex Microcontroller won't connect to the Joystick via VEXnet Key 2.0

My Vex ARM Cortex Microcontroller won’t connect to the Joystick with the VEXnet Key 2.0.

I have two Vex ARM Cortex Microcontrollers. I’ve been using one for several years. I recently tried to use the other Cortex that I haven’t used in several years. I used VEXnet Firmware Upgrade Utility (v 4.1.7) to update the Joystick and Cortex firmware. I used VEXnet Key 2.0 Firmware Upgrade Utility to update the VEXnet Key 2.0 firmware.

The Joystick and Cortex still connect on the original Cortex, but not on the second one.

Here are the lights:
Joystick

  • Joystick: solid red
  • Robot: not on
  • VEXnet: flashing orange (yellow?) medium fast
  • Game: not on

Cortex

  • Robot: flash green slowly
  • VEXnet: flashing orange (yellow?) medium fast
  • Game: flashing orange (yellow?) very fast

The battery connected to the Cortex is fully charged.

Any suggestions? Thanks!

Did you pair them bye connecting them with an orange USB cable first?

4 Likes

Yahoo! That worked. Thank you.

Always read the manual

1 Like