VEX Code 1st Gen Brain

A team of mine is using a 1st generation brain, updated to VEX OS 2. When it’s connected to VEX OS it says it is up to date. However, when they go onto VEX IQ Code it will not let them download their program because it says their brain is not up to date and needs to be connected to VEX OS.

Any help would be greatly appreciated.


My team has the same issue! Try to update it again until you can download it same on the controller since OS is downloaded in segments.

We just released VEXos 2.2.1 for VEX IQ Brain 1st generation. You will need to update to that version to continue to use the brain. if you ware unable to update the VEX IQ brain right now.

The VEXos Utility will require internet access to find the updated firmware. If you are using a school computer or network for this, it could be that the connection is being blocked by the school firewall. That would explain why it is unable to get the current firmware version.

Until you are able to update your IQ Brains, you can use the web version of VEXcode IQ ( We have removed the version check from the web version to give schools an option to work around this until they are able to install the updates.

If you need instructions on updating the firmware on your VEX IQ Brains, you can find instructions at

Please note, that this update will require you to update the firmware on your motors as well.



We just tried to use the web version of VEX Code and we are getting the same error message that the VEX OS is not up to date and the brain can not be connected. We also tried to update on VEX Utility and it says version 2.2.0 is the most up-to-date. So I am guessing there must have been a change in our school’s network that may be blocking the current version. However, the web version of VEX Code is not working for us either.

The web version of VEXcode IQ will still tell you that your IQ Brain needs an update if it is out of date. However, it will still let you download projects to the brain even when it is out of date. You will need to click out of the update message to continue to use VEXcode IQ, but it will still work.

Are you just seeing the update message (below) or are you trying to download a project?

If you are trying to download a project and the download button is disabled, please try the following.

  1. Make sure that the version displayed in the about screen (File → About), is 3.0.1-10. If you see a different version, there is probably a caching issue and we will need to clear the cached version so that you can access the current version.
  2. Refresh the VEXcode page and reconnect to the brain. There is an issue where VEXcode can think that the brain can not have any data sent to it. Restarting the app (page refresh in this case) fixes this.
  3. Try restarting the browser. Since all the communications with the hardware for all the web versions of VEXcode are passed through the browser. So if there is an issue with the browser, a restart of the browser is a good first step to fix this.

If you are trying to download a project to your out of date IQ Brain and it is not letting you, can you please submit feedback after the download fails? Please make sure the diagnostic data is included and reference this thread post so that I’ll now it is from you. This will let me see what VEXcode is doing that would prevent you from downloading.



I had my IT department look into a firewall or something else blocking the download and there is nothing that seems to be blocking it. I tried to force a download at school and it just downloaded 2.2.0 again.

I also brought the robot home and tried on my network, just in case, again it says I’m up to date. I forced an update again, and again it only updated to 2.2.0.

Any suggestions on how to get 2.2.1?

I’m not sure why it would not be pulling the current firmware.

For right now, we can try to pull the firmware update directly and load it on your VEX IQ Brain. Since this firmware also updates the motors, I would recommend that you have all your motors connected to the IQ Brian before you start the update so that they can all get updated with one pass. Otherwise, you will need to repeat the process to update the motors later.

Update steps

  1. Download the firmware file directly from
  2. Open the VEXos Utility (make sure VEXcode is closed)
  3. In the VEXos Utility, right click on the brain icon and select “Select File” (your interface might be slightly different but the Select File option is the same)
  4. Click the “…” button and select the downloaded .vexos file
  5. Install the update on your IQ Brain by clicking the Install button.

Thank you that worked!

1 Like