VEX Code V5: make process closed with exit code : 2

Does anyone know what this error means?

3 Likes

yes, it means that it is not working

But… what is the cause behind the error?

are you using the latest version of vexcode?
I believe this was an issue with some of the past versions

1 Like

I’m actually not sure. Can you send me a link to the latest version?

I have version 0.9 and still have this error.

Sure: https://www.vexrobotics.com/vexcode-download

Alright, I redownloaded and everything but it still isn’t working. It has the same error

try downloading a program you know works, like a sample program. this way you can narrow down whether the issue is your code or not.

1 Like

Hmm, it did indeed build this time without the error.

what did, the sample program, or your original program?
if the sample program went fine and your program didn’t, then post your code here so we can try and spot an issue.

The sample program. One second, I will post the code.

looks to me like you have other errors in your program, which would explain why it doesn’t properly compile.
Now, I may be completely overlooking something or getting this really wrong, as I’m not in any way an experienced coder, but you appear to be missing your global definitions of motors and such.
things like

vex::controller  Controller = vex::controller();

or

vex::motor LeftFrontMotor = vex::motor(vex::PORT1);

and things like

using namespace vex;

now, I see you have something that says

#include "robotConfig.h"

I know absolutely nothing about what this does, but I suspect it might be letting you configure all your motors and such in another place. if this is the case, and you aren’t missing such configurations, then I’m afraid I can’t help.

1 Like

Hmm. I don’t have the using namespace vex statement, I instead have #include “vex.h”. I will try putting that in and seeing if it works. And, yes, all the motors and such are declared in robotConfig.h. Thank you so much for your time!

1 Like

may I inquire how you make separate files for things like your robotConfig.h?

Separate files as in?

Oh, I just right click on include and click new file, then format it as a header file. Then, I reference it in the src file

woah, that’s pretty cool. thanks!

Yep, for sure. Oh, by the way, here’s the full error. This is probably a lost cause, but before I move to some other coding software maybe this can be salvaged.
image

hmm… I really don’t know whats wrong. have you tried restarting vexcode/your computer?