Vex Cortex Microcontroller


Our Robotics team just got our robot set up but it will not respond to basic controls.

We built a basic tank with 2 2-wire motors connected to the motor ports on the cortex micro-controller. The battery is charged and properly attached as stated in the manual. We connected the Vex Joystick to the microcontoller via tethering cable and left it for 1 minute and then tried to control the motors with the joystick but it did not respond.

The center light on the vex joystick is flashing red and all 3 lights on the cortex controller is flashing orange,

The binder that came with the kit said that starter code was pre-uploaded on the micro-controller so programming was not necessary on first run. We have Googled + searched these forums for solutions but so far none of them have worked (we may have done something wrong).

Can someone help us get our robot to work please?

do you have any programing software?
updating the master code would be a good way to start.
which light on the joystick is flashing?
when you paired the two units, what lights were flashing? and what colors?

Yes we have programming software.

There are 4 led on the vex joystick, so there is no middle led.
Also every LED has a name above it, so you can reference them by name.
for additional instructions on tethering with the USB A-A cable.
If the Vexnet led is not green, your remote wont work.

Google vex cortex flash led
has additional links for helpful information.

The “Robot” led is flashing red on the Vex Joystick and all the leds on the Cortex microconroller are flashing red.