VEX Cortex Solid VEXnet light

Hello!

I have a problem that results in the Cortex’s VEXnet light becoming Solid Green, and the robot unresponsive (no code running, no link, no activity detected)

Steps:

  1. Put a VEXnet key in the joystick.
  2. Put a VEXnet key in the robot. (Bonus points if the key is already hot or unreliable :rolleyes: )
  3. Turn on the robot
  4. Turn on the Joystick
  5. Watch them attempt to link
  6. Watch them almost barely just link, the motors twitch, and the Cortex drop to a solid green VEXnet light, and become completely unresponsive (except to being turned off)
  7. Watch the joystick be slightly optimistic and think it’s linked for a second but then realize the truth that the link is lost, and sadly slip into a red VEXnet blink pattern (can’t remember if it’s one or two blinks though)

Also, I only noticed this problem after upgrading from ROBOTC 3.04 (with the Master Code/ VEXnet firmware that came with that) to ROBOTC 3.05 (with Master Code/ VEXnet firmware file CORTEX_V3_20.BIN)
It may be that I didn’t upgrade the Master firmware on both joysticks, and I shall look into that, but I recall it happening with both of them so… :shrugs:

According to the Cortex User Guide, a “Solid (green)” VEXnet light is an “Update Utility Tool Indicator” which indicates “Tether to PC”. Does this mean my VEXnet key is bad? I’ve tried several different keys, and they all seem to have this problem at one time or another.

Thanks!

–Simmons 2.0

This means you need to update your vexNet firmware using the vexNET upgrade utility.

See Post #3 here for more detailed instructions on how to do this.

Thanks for the suggestion tutman96, and ManicMechanic!
I checked the firmware using ROBOTC, and I do have the latest version on all joysticks and the Cortex.

Here is a video of the cortex going to a solid green VEXnet light:

(The lights on the cortex go: (from left to right in the video)

  • Robot
  • VEXnet
  • Game
    The lights on the joystick go: (from top to bottom in the video)
  • Joystick
  • Robot
  • VEXnet
  • Game)
    Has anyone seen this happen before?

Does this happen when you use the A-A cable between your cortex and controller?

I have seen this before the best thing isto download the firmware again it may have lost something important,

RobotC V3.05 is using newer firmware than the upgrade utility that is currently posted on the Vex wiki, so this is not a good idea.

For the record
VEXnet firmware upgrade utility V3.1.6a would load master and joystick firmware version 3.16.

EasyC 4.0.2.8 has the upgrade utility V 3.1.13 that would load master and joystick versions 3.17. Yes, that’s not a typo, strange versioning, go figure.

RobotC V3.04 has it own upgrade code and loads master and joystick versions 3.16

RobotC V3.05 has master and joystick versions 3.20

This post, an answer to one of my attempts to get more detailed release notes, claims that a joystick with version 3.16 should link with a cortex with version 3.20, I did try that with a USB A-A cable and confirmed it, but did not try with wifi keys.

I have tested RobotC V3.05 with wifi and can confirm it does work.

Anyway, none of that really helps you with your problem, here is what I suggest as a means to find out which part is broken. This assumes you have loaded RobotC user firmware V907 and don’t have any crazy code running that is crashing the cortex.

  1. Check the batteries, I’m sure you have but this needs to be step 1.
  2. Try using a USB A-A cable as FirePhoenix suggests and see if that works
  3. Try two different wifi keys
  4. Try a different joystick if you have one, you will need to tether with the USB cable first before using wifi.
  5. Try a different cortex, same method as above.

You should now be able to determine which part of the system is faulty, wifi keys, cortex or joystick. If it’s the cortex or joystick then reload the firmware. If you don’t have a spare cortex or joystick then just reload the firmware in both.

Since today we had a competition and 3086C had the same problem went back and redownloaded the firmware and it worked.

Where is this newer firmware? Can it be downloaded so that v3.05 can be used? If not, is an older version of RobotC available which is compatible with the currently available firmware?

Each version of RobotC includes the appropriate firmware, so the 3.20 master firmware is included with RobotC Version 3.05 and can be installed into the cortex and joystick from the “robot->download firmware” menu.

That’s what I thought – so I was puzzled by what you meant by this, as I hadn’t seen a previous reference in the thread to the Vex wiki:

We’ve found that whenever we need to download the firmware, we might as well got back to the original website to get the latest version of software as well (http://www.intelitekdownloads.com/easyCV4/ or …/easyCV2/for EasyC, not sure where for RobotC). Though software installation adds a few minutes, we figured it’s worth it if we’re reinstalling firmware anyway.

or …/easyCV2/for EasyC, not sure where for RobotC). Though software installation adds a few minutes, we figured it’s worth it if we’re reinstalling firmware anyway.

While going to the Original S/W site for the latest Version of S/W and firmware should always result in a matching pair. Sometimes there are reason not to risk an upgrade to the development environment (Robot C or Easy C) just to reload the Firmware of the Cortex / Joystick. We have seen several times that the Cortex and Joystick no longer link properly These are usually cleared up by swapping USB keys, or occasionally we had to reload (the same version) of the Firmware to either the Cortex or Joystick. We go through the same Steps outlined above. Jpearman’s reference to the wiki noted the Vex Wiki [https://vexforum.com/wiki/index.php/VEX_Cortex_Microcontroller has a very old version of Firmware. not current for either recent Easy C or Robot C and loading old firmware should be avoided. But reloading the same version over again can sometimes clear up problems.
Cheers Kb](https://vexforum.com/wiki/index.php/VEX_Cortex_Microcontroller has a very old version of Firmware. not current for either recent Easy C or Robot C and loading old firmware should be avoided. But reloading the same version over again can sometimes clear up problems. )

Simmons 2.0,

Based on the video it appears that one of your keys is failing to maintain the VEXnet link.

Do this happens while connected with the USB A-to-A cable?
Have you tried a different set of VEXnet keys.

-Eli

Thanks for your suggestions, all!

When I try to update the VEXnet firmware (master code) on the (joystick?), ROBOTC just says, “Nope! You’ve already got the latest firmware, so no need to update!” And then it stops before updating.

Maybe I should downgrade, and then re-upgrade the VEXnet firmware (master code)?
I should note, that this dropping to a solid green VEXnet light on the cortex issue doesn’t happen all the time; it only happens sometimes, and usually it only happens after we’ve used the robot for a while.
Yes, we have five or six VExnet keys, and we’ve tried lots of different combinations with the different keys. We’ve also tried swapping out the keys from the Joystick and the Cortex when we experience this issue. Sometimes it stays solid green, sometimes it does let us link for a while, but eventually the cortex will always drop to a green solid VEXnet light no matter what VEXnet key pair we use (We have even used known-good VEXnet keys that IFI shipped to us when we had a different issue!).

This seems to happen even with fresh batteries in the cortex and Joystick (recently finished charging, and good green lights on Joystick and Robot)
I’ve also tried using our 2 different Joysticks to try to connect with the Cortex, and they both seem to cause this same problem.

We have tried tethering directly using a USB A-A cable between the Joystick and Cortex, and it will link just fine and stay connected, and doesn’t seem to drop at all. Interestingly enough though, the instant after we unplug the USB - USB cable from the Joystick, the Cortex will drop to a solid green light just like before. Re-plugging in the joystick allows us to regain the link instantly as well, and repeated unplugging and replugging the USB cable from the Joystick seems to continue this pattern as expected (works when it’s plugged in, cortex drops to green light when it’s out, then it works when we plug it back in, etc)

Now, my hypothesis is that this issue is from three problems:

  1. A problem that we were experiencing before we upgraded to this VEXnet firmware (master code), where we turn on the cortex and joystick, the cortex attempts to link, links, then drops link, but then attempts to link again and succeeds.
  2. Perhaps there was a change made in the most recent (3.20) VEXnet firmware (master code) which causes the Cortex and/or Joystick to only try one link attempt, and if it fails, just drop to a green solid light on the Cortex.
  3. Our cortex is bad in some way. Our team doesn’t have another Cortex with which to test this theory, but I can perhaps do this at an upcoming tournament if I can find a team with an extra Cortex.

Thanks so much for all your help!

We’ve had the exact same problem with our robot, and lost three matches in a past competition after the cortex light random switched to solid green. The solid green light means the brain is tethered, according the vex net LED sheet, and we downloaded the latest firmware, and it still didn’t work. However, we noticed that when the vex net key was not in the cortex, the vex net light was still solid green, so we replaced the old vex net key with a newer one, and sure enough, everything works great now.