Vex Forum CSS Not Loading

Hi Forum,

So I logged on to Vex Forum today, and I found that none of the css is loading. I have tried it on both Microsoft Edge and Internet Explorer. I have tried rebooting my PC. I have also visited other sites which seem to be working fine. I would attach a screenshot of what I see, but it won’t let me attach anything to this post. Any ideas?

Thanks

Hi Mr. VEX,

We performed some small server maintenance this morning, which might be the cause of this issue. Can you please try to clear the cache in your browser and see if that fixes the problem?

Let me know if this works!

1 Like

Looks like your forum is trying to load CSS over HTTP instead of HTTPS. For a permanent secure solution, I recommend you look into IP over avian carriers.

Try again, All CSS URLs on the site start with // so they’ll use whichever protocol you hit the site with.

Ya same thing is happening here…

Clearing cache didn’t work.

Clearing cache did not work.

Interesting, for me Chrome on OSX and Android does not work, Chrome on Windows does.

It started working only after I told chrome to allow unsafe scripts.

It started working for me again randomly :wink:

could be a DNS level caching issue then? those usually take a while to resolve


ipconfig /flushdns

Chrome says its loading data from unsecure sources. I allowed it to load the data and it was fine, but it seems to have lost its https security.

The unsafe scripts thing worked but the forum still doesn’t look 100% normal. Seems to be an underlying issue. And ya it has lost its https security.

Still not working for me. (using this URL as reference https://vexforum.com/t/vex-forum-css-not-loading/37180/1)

Chrome console says:
Mixed Content: The page at 'https://vexforum.com/t/vex-forum-css-not-loading/37180/1 was loaded over HTTPS, but requested an insecure stylesheet ‘https://vexforum.com/’. This request has been blocked; the content must be served over HTTPS.

When viewing source, the only one that has http is this one.
link rel=‘canonical’ href='https://vexforum.com/t/vex-forum-css-not-loading/37180/1

Clicking this one does not resolve with the ? part. I also notice it does not have the // up front
link rel=‘stylesheet’ href=’/cache/css/base,font-awesome,styles,colors.css?1477947633’

Same with:
/cache/js/jquery,jquerymisc,jqueryhistory,jqueryscrollTo,global.js?1477947633

and

/cache/js/jqueryautogrow,scrubber,autocomplete,conversation,signature,jqueryfineuploader,attachments,jquerycolorbox-min,attachmentslightbox,share,bbcode.js?1478092301

Everything looks fine for me. Weird.

It is fine at home but at work where they run us through proxies and strictly enforce non-mixed security types it is busted.

Chrome Version 54.0.2840.71

The only non-ssl URLs I see on this page are the gif from imgur and your footer.

It’s working again for me! Thanks for the change.

I’ll change my footer. We recently added SSL to our site. Let’s Encrypt via Dreamhost where we run things.

Changed my footer too :slight_smile: