Vex iq 2gen brain stuck on vexos update screen

Vex brain crashed while updating firmware. The vex screen is stuck with “update vexos” written as seen in the image.

When VEXcode IQ is turned off, the vex brain is connected to the computer, it sees the drivers without any problems. But when VEXcode IQ is open , the vex brain is completely locked, the off button doesn’t work. We have to reset it by removing the battery. When we remove the vex brain and plug it back into the computer, it gives the error “USB Device not recognized”. In summary, we cannot re-firmware because VEXcode IQ does not see the device. (Tried on 4 different computers)

Is there a way to update the firmware without connecting the vex brain to the computer? (eg SDcard)

Sorry to hear you are having issues updating.

Is this a brand new brain ?

When you turn the brain on without the USB connected, do you see the animation (the moving blue rectangle) continue to run or does it stop after a few seconds ?

I’m seeing colored horizontal lines on the screen, are they present as soon as you turn on the brain ?

6 Likes

The brain is not new, received in January.

The animation continues to run when the brain is not connected via usb. The animation works until I run the Vexcode IQ, then it freezes.

Yes, the colored horizontal lines on the screen appear as soon as the brain turns on.
Thanks for your interest.

Full disclosure, I am a VEX employee.

My best guess, based on this information, is that this brain either has a hardware fault or is not recoverable by the public tools (ie. VEXcode). Was the brain working before an update was attempted ? vexos 1.0.4 was released back in February, any reason for delaying the update ?

anyway, my best advise at this point is to contact our support department and have the brain replaced.
https://www.vexrobotics.com/contact-us#offices

7 Likes