Vex iq 2nd gen brains both will not work prompting for VEXOS update

The problem

We have two vex iq gen 2 brains, both not functional

The first brain - specific problem

For our first brain, it suddenly told us to update VEXOS a few weeks ago, and at first the update got stuck for a long time, over 30 min. So that day, we retired the update and switched to the 2nd brain. The next morning, the update suddenly worked but we didn’t switch back. We thought it would be functional after our 2nd brain broke, but it still randomly prompts for an update to VEXOS sometimes, though it cannot be recognized by our computer. Some other times, when we restart the brain, it does not prompt for an update but will randomly crash in use, seemingly without any pattern and prompt an update for VEXOS once we restart it once more.

The 2nd brain - specific problem

The 2nd brain suddenly prompted us for an update a day ago, and vexcode iq is able to prompt us to update when we connect the brain. However, the progress bar on vexcode iq would always reach the same point at about 65 or 70 % before it says “Firmware update failed! Try again.”. Even more strangely, vexcode iq seems to think the brain’s VEXOS version is 1.0.0, even though I remember we updated it a version above that around two months ago.

this is an image of the brain being connected to our computer


Please help us try and find a way to fix at least one of our robot brains! There will be no way we can improve our autonomous or attend the State Robotics Competition without resorting to our old Gen 1 brain and completely rewriting all of our code! Please let us know if there are any other examples or resources we can provide to help you help us fix this!

It sounds like that one has a hardware fault, contact vex support.

because we released vexos 1.0.7 on Monday.

probably because the update failed and you are in the boot loader (animation of a brain and PC indicating you should connect them).

You can try the usual things, a different cable, different USB port etc. make sure no other programs are open that may be trying to communicate with the brain.

use feedback after trying to perform an update that fails and reference this forum topic, dev team can then look at the logs and see if there’s anything to learn from that.


Kay, thanks! How do we contact vex support or use feedback after failing to update?


and the feedback button


We looked at the logs in feedback and it’s not giving any useful information beyond indicating that a firmware update starts and the brain then disconnects a couple of minutes later.

It seems you are using a Mac with an older version of Monterey installed.
If possible try another computer.
you could also try using the web based version of VEXcode at and see if that works any better (make sure to close the VEXcode app).
Is this a direct USB connection or is a hub involved ? Try an alternate connection and cable if possible.


Thanks. We have tried using both this mac and a ASUS laptop and 2 different cables, and the problem still remained the same, is it possible this is the brain’s fault?

That’s about all we are left with, I suggest you contact vex support regarding this brain also.
Just for my interest, what are the numbers at the top of the bootloader screen ?



V1.0.0.8 ID:1F3217

these are that numbers at the top of the bootloader screen for the 2nd brain

Also, should the bootloader be displaying an animation? It seems to be frozen right now.

If you turn the brain on and the animation freezes when not connected to the Mac, then that’s pretty conclusive that the brain has a hardware issue. Contact vex support, reference this thread if necessary, and get the brain exchanged.


Is it possible that this is a broken flash memory chip? I saw your response to a previous post detailing the same problems that we have.

Yes, It is possible.


I am having the exact issue with a gen 2 brain. The brain indicates an update, will plug into both a chromebook and a desktop, with two different cords, and will fail the software update each time I try.

To note: I purchased a gen 2 classroom pack in Jan 2022, and 2 of the brains permanently failed and would never update again. Such a frustrating waste of money.

I will follow this thread to see if anyone figures out a solution. I will also update if I figure out a solution.



If you have followed through will all the suggestions in this and other threads, contact VEX Support who will help you out. If it is a hardware issue as alluded to above, then VEX Support will be able to help you and make sure that it is not a waste of money.

I am having the same problem right now, what do I do?