VEX IQ 2nd gen controller with blinking red power light

I had a student whose controller power button started blinking red. It will not charge, link to the brain, or connect in VEX IQ software. We have tried multiple cables, we have swapped out fully charged batteries, and I have tried to connect to multiple devices, including a desktop, a chromebook, and my own laptop. No luck on any front.

Is this controller bricked?

Best thing to do is contact Vex support, right now Vex Iq gen 2 is new and non of us will have solutions.

Well, dang. Thanks for the heads up. I will do that.

1 Like

Does the small controller icon in VEXcode turn orange when the USB cable is plugged in ? If so, click it and select update firmware.

2 Likes

It does light up orange, but it says the current version is “0.0.0” and gives an error when you try to update.

Sent you a DM with something else to try.

2 Likes

Hi, Did you figure out what was wrong? I’m having the same issue…

I contacted VEX directly. and they wanted to replace the battery. I tried that on my own with a different controller battery, and it did not work. After leaving the controller alone for a few weeks, the problem went away, which I know is not a great answer.

Interesting. Thanks so much.

I had the same issue and reached out to VEX Support, these were the directions I got from them:

  1. Install the App version of VEX IQ Code If they already have it installed, then good. We basically just need the drivers out of it. Leave the app closed.
  2. Open VEXcode IQ web based version:
  3. Connect the bricked controller into the PC using a USB cable
  4. Click on: Controller> Recover (Fast Red Blinking)
2 Likes