Vex IQ Blocks - Print Function

Good afternoon,

I want to teach students how to display distance or any other variables on the Brain Screen, and for some reason, when I add the “print” function to my program, the brain just kicks out an ‘error 4’. Any advice would be appreciated. I have also updated all the firmware. I am also using the VexCode IQ blocks for reference.

Thanks

Update

I have narrowed it down to the Play/Run feature in the Block code menu. If you download the code to the brain and run the program directly from the brain, no error occurs. However, as soon as I hit download and run the program from inside VexCode IQ blocks, it kicks out the error. This is a little frustrating as everything else seems to work.

I also have noticed that the play button doesn’t always have the best behavior… While I haven’t seen the error 4 that you have, it will sometimes run the program correctly but then the brain will still look like it’s at the main menu.

Somewhat related - we were trying to get the brain to display the current position of the arm in degrees. It’s a 1:9 reduction; about a 120* throw, so we were expecting something around 1,000 degrees.
The printout was 000.000.000.000.000 to 000.000.000.000.006.
We tested both degrees and turns; we never got any results from turns.
Any ideas?

1 Like

Could you post your code? Something like this should work:
image

3 Likes

Ah the wait - clear all rows combo makes sense. Thanks!

1 Like

Can you please post your project so that we can take a look at what is happening?

This is the first time we have seen any reports of an issue like this, so we need to see if there is a specific combination of commands that could cause this, or if there is an issue with the generated code. Since we have not seen this before, the fastest and most reliable way to check this is to look at a project that is already having the issue.

2 Likes

Are you using PC, Mac or something else ?

As Jacob requested, please attach a program to this topic that demonstrates the issue.

3 Likes

I am using a Mac & OS Mojave. I tried many different sets of code but here is an example of a simple timer that also throws out the ‘Fatal Error Detected’ ‘Error Code 4’ and requires a reboot of the brain.

37

Tried that code and it worked for me without issue.
Have you updated the brain to the latest vexos which is 2.1.3 ?

5 Likes

Yes I have updated the brain to 2.1.3 and all the sensors as well.

Still giving me the same error.

After we updated the firmware this weekend our teams robot started to have the same error “fatal error code 4”. The error message is coming up when we hit to run the program, and happens only on programs that include the controller. It happens every time the run button is hit from the computer and occasionally when the program is started from the brain.

That’s a known bug in VEXcode, update the IQ to the latest vexos to solve.

5 Likes

We are on version 2.1.4. Is there something else we need to be doing to fix the issue?
image

1 Like

This issue should be resolved with using VEXos 2.1.4 and VEX IQ Blocks 1.0.8, which was released on Dec 20th.

3 Likes