Vex IQ Blocks

We have a team that recently updated their VEX OS to version 2.1.4. They then tried to download an already created program and it keeps coming up with an error message when trying to download. To troubleshoot, we downloaded the program to another team’s robot that was running on version 2.1.3, and it worked fine. This leads me to think that the newest version is not compatible. Has anyone else ran into this issue, and if so, do you have any solutions for me?

What was the specific error message?

What was the content of the program in question?

Are you running the latest version of VEXcode IQ blocks (1.0.8)?

We had all kinds of issues after updating to the latest Vex Code blocks and the brain to latest OS. Since then, We had errors when downloading to the brain and only got around the errors after about the 8 or 9th brain restart. Other issues included the autonomous program making the robot spin in circles when it hit the line of code where the gyro was. Erasing the brain and reinstalling software didn’t work either. Our autonomous worked before the latest VCB but not after. And when opening our previously working program in the new VCB, it would get errors on compiling before it downloaded to the brain.

Not sure if the issues are in the brain OS or VCB, bu there are issues.

We are looking for a source to get the previous version of VCB to “downgrade”

The message stated “error while downloading, trying attempt 2 of 2.”

It was a simple program to stack two green cubes, and worked fine before the update and on another teams robot when troubleshooting.

It is the current version of Blocks.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.