VEX IQ Brain Frozen during OS Update

20200206_193206

Please see the picture. We are seeing that in our brain. It happened while updating to 2.1.4. It is frozen there. Can turn off the brain. We have tried the up and down buttons and turn on the brain. But it still shows stuck here. Even connected to the PC - VEXOS util shows that it still needs to be connected.

This is likely a Windows driver issue where the computer is not recognizing the IQ Brain in firmware update mode. Open the device manager on Windows and see if the IQ is appearing in the device list… are you on a a school computer that may have restrictions on installing new devices?

image

This is what is in the Device Manager - Win10

We have used this same computer for the last 2 years. But first time did the OS Firmware upgrade. it seemed like it was working. Could see the status bar as it updated the firmware. Then it said the controlled needed updating - so we clicked that and that’s when it started showing this - picture above: vex.com/os

Just bought the brain new this summer.

I had this happen as well. I literally spent 20 minutes wiggling the cord at the brain and computer and holding it right before it finally did the update

Sorry for the delay - this thread got lot for me somehow…Drivers are installed properly. Also make sure VEXcode (or other applications) are closed when running the VEXos Utility.

Can you post a screenshot of what the BEX is utility shows as well?

1 Like

Sorry and thanks for following up. You are right…had to restart pc and ensure only the VEXos for running and restart the firmware update. That worked.