Vex IQ Controllers refuse to charge

We purchased 5 Vex IQ super kits about a year ago. I thought during this time we had been charging our controllers at various times. But, we found out recently that one controller finally died. I now realize that these batteries last for dozens of hours. It was at this time I realized NONE of our controllers charge.

It is the exact same thing for all 5 controllers. When they are plugged in we see the same behavior, the charge/game light turns red for around 3 seconds then turns green.

Things I have tried:

  • Using different USB/Data cables supplied in the original kit plugged in to USB wall chargers.
  • Using different USB/Data cables supplied in the original kit plugged in to USB ports on a computer.
  • Using an aftermarket USB data cable plugged in to a USB wall charger.
  • Tethering the controller to the multiple different brains
  • Turning the controller on or off while the charging cable is plugged in - each transition of power results in the same 3 seconds of red light then green.
  • Leaving the controller sit with the green light for quite a while while tethered to a brain. The controller still doesn’t turn on when unplugged from tether.

I just don’t get it. 5 controllers, none charge, on any of the described methods to charge them? Doesn’t make any sense.

You did EVERYHING except to swap a battery from a good controller (and the other way) to see if it’s a bad battery or a bad controller. Battery is under the buttons, you’ll need a small Phillips screwdriver to get it open.

@Foster, thanks for the reply. But, it would seem un-necessary to do this, if I literally have 5 controllers and batteries that do not charge.

@appleoddity, no problem. Across the years I’ve never seen a controller that wouldn’t charge, but I’ve had controller battery packs that stop charging. Please post what the final determination of the problem was. Thanks!

@Foster, Thanks for the follow up. So, I dug in to this problem last night. I was thrown for a loop when one of our controllers stopped turning on. I assumed it was because the battery was dead - and it was the first one I noticed that would not charge. After that, I tested all our other controllers, and they would not charge. All exhibited the behavior I stated above.

However, last night, I found that after removing and reinserting the battery in the “bad” controller that it would power on again - but still would not charge.

So, I checked voltages on a couple of batteries. Mind you, the battery is rated at 3.7v 800mAh. The voltage reading on two batteries was 3.97v and 4.19v. These are batteries that have been used for months, likely without being charged. So, clearly the batteries had a good charge. I decided to completely discharge one of the batteries overnight. I tested the controller periodically, and it started to show “low battery” at around 3.8v. Today, I reinserted the battery and it is charging normally.

So, a controller stopped turning on which led me to believe the battery was dead when it was actually charged. Second, I am very confused by the fact that we can use these joysticks for months (many hours) and they don’t need to be charged, even for 10 seconds. Last, the batteries are putting out far more volts than they are rated at, even when they haven’t been recently charged.

It would seem to me the batteries are not labeled properly on their voltage rating, and all 5 of my joysticks are “fully” charged even after heavy use over a period of months.

It doesn’t all add up, but at least now I know I can charge the batteries when they are truly run down. There must be a threshold mechanism in the charging circuit that allows the battery to fall below a certain level before it will allow it to charge, and then it charges it in one setting to well over that threshold so that it can’t be charged again for quite a long time.

EDIT: From completely dead drained, to full charge (according to the joystick) in about 1 hour. Final battery voltage 4.00v.

Thanks for the super detailed analysis! I’ll put this away in my collections of strange things that may happen. From your analysis I may have replaced some controller battery packs when they didn’t need it.

It would be interesting to see what VEXIQ tech supports thoughts about this were.


Reading this, because I am again experiencing issues with the controller batteries. I have 2 controllers and 4 batteries. I had 1 controller that blinked red all the time (plugged in or not). I tried out to 3 other batteries in that controller (one I knew was charged). Same red blinking. Then I put the original battery back in, and I got the solid red charge light. It has been red for 12 hours now. The other controller has been charging another battery for 12 hours now too. I unplugged, and am getting green on both. Confused, but I think it’s working.