Vex IQ gen 1 problems

I cannot get my controller updated to the latest version.
Here is what I have tried :
downloading the newest utility for gen 1.
Hooked up the brain and the controller to the computer
Run the utility.
The utility says “everything is up-to-date” and then says “usb error”. Tried several usb cables.
The BRAIN says this " Controller must be updated to the latest version"
This has happened at the beginning of a two week lesson, so I am at a loss how to proceed. I am sure I have missed something, so if you can find the error, please let me knkow.

Do you have the controller tethered to the Brain using the tether cable?

When you connect the Brain to the computer via USB, is it detected by Windows in Device Manager?

Do you have VEXcode open at the same time as VEXos? You should only have VEXos open.

Is the Brain able to connect to VEXcode?

This is a big one that I think many people miss. If the brain is already talking to the computer via VexCode, it does not like communicating to Vex Utility also. Only have one of those open at a time.