VEX IQ help....brain not recognized

Folks, I’m using the VEXOS utility but it will not recognize the VEX IQ Brain. What I have tried already:
I have downloaded the latest version of the utility.
I have tried three different cables in hopes it was the problem.
I have tried one PC and two Macs.
I have tried every possible USB port.

Still every time the utility will open fine but it cannot see a device connected. I typically turn the brain on after connecting the device to a PC/Mac.

I’ve tried the online chat with VEX. First they say they are busy, despite me being first in the queue, and want me to email them - which will probably make for a generic answer. So far they have been no help.

I bought Bluetooth radios for the brain but it needs to be updated to use them so I may have to send them back.

Any advice from you VEX IQ veterans out there? We are still in the shallow end when it comes to experience.

Villebilly

@Villebilly - Do you happen to have any other VEX IQ apps opened at the same time? If VEXcode is opened at the same time as the VEXos Utility, they’ll conflict and prevent the update from working.

3 Likes

Great suggestion. But I haven’t even used any other VEX apps. Was hoping to use the Bluetooth radio to connect iPad to robot but so far no luck.

In Windows Device Manager, do you see two active VEX devices under Ports(COM&LPT)?

1 Like

I don’t see anything in the Device Manager (Ports / COM & LPT) that relates to VEX…

Have you tried using a known-good USB cable? (or, alternately, have you verified the USB cable you’re using to be good by using it with some other device?)

1 Like

I have tried three different cables. VEX has acknowledged that some of their cables have had issues. The other cables I have tried work when I use them for charging other devices.

Thanks for your suggestions. Keep bringing them.

You could try holding the Up and Down button on the VEX IQ Brain while turning it on (pressing the check button). This will force it into Bootload mode.

At this point the VEXos Utility should see it - definitely on Mac since no additional drivers are installed for Mac.

The only other thing I can think of is if any other application (a serial monitor or something of that nature) is stealing access to the device.

2 Likes

I just tried that on Mac laptop. It came on in DFU mode and said “Connect to PC for program update” but the VEXOS utility still did not recognize it.

Brain is on v2.0.2

Hmm… This is seeming more and more like a bad USB connector on the brain itself. How old are these IQ brains?

1 Like

The brain is about 1.5 years old.

If they had made the bluetooth radio so I didn’t need an update I could live with that. Or they could have made it so it update through the radio. So now I’m stuck.

can you verify that the VEXos utility was downloaded from this page (occasionally customers grab the V5 version by mistake).
https://www.vexrobotics.com/iq/products/vexos

Has USB on the brain ever worked ? What has been used over that last 1.5 years for programming ? ROBOTC, EasyC, Modkit ?

On a Mac you can verify the brain is recognized by checking system information and selecting USB
you should see something like this.
image

In windows, in the device manager, you would see this.

image

If suitable drivers are not installed, this would show on windows 10

image

If none of that shows up then VEXos utility will not be able to connect to the brain as the PC/Mac is not detecting the hardware.

6 Likes

I just downloaded again. We had the correct utility already.

We have not used the brain for programming since Robot C is not Mac compatible. We thought having the Bluetooth radio would help my son get programming with Vex by using the iPad.

Yes, the PC/Macs are not detecting the brain…that is my core issue to resolve.

based on everything you have told us, it seems the IQ brain USB is defective, not much more we can do.

2 Likes

Yeah that’s what I was afraid of. It is sad since it has been connected probably five times or less. I was hoping to get this rolling by having my son start programming and then invite other families to start a team. Now I’m left with a dumb remote control toy.

They had better allow me to return these Bluetooth radios. I already wasn’t happy to pay $15 in shipping for something that weighs less than an once.

I think once you send your brain back and they fix the USB issue and you are on current firmware that your Bluetooth radios will work. That will then let the iPad connect to the brain and send down the code.

As an aside, shipping has always been an issue since Amazon started with “free shipping”. And remember, shipping isn’t “free” you are paying for it someplace else.

Shipping is made up of the box/packaging, the time to find the part, put it in the box, and then the FedEx charges to deliver the box. VEX seems to have a minimum ship cost (around $15). But you can add more things to the box for the same price until it moves into the next weight category. So I always try to get $50-70 of parts in my box before I press the ship button. It also helps the environment since most places don’t recycle cardboard (limited market for resale) and there is no sense in me killing a tree to get a bag of 1x1 VEXIQ pins.

On the other end of the scale, the cost to ship field perimetry, floor tiles and game elements. I had a skid full of stuff for new teams and the shipping was a cool $650.

Good luck with your brain replacement.

1 Like

No wonder sometimes it does not work for some of my students.

Thanks a lot for pointing that out!

Can I send the brain back? At what cost?

Although our VEX building is still in its infancy, I have found the community to be quite helpful. Others have told me the same.

I work for UPS so I get how shipping works (since it is my personal money we buy only what we need, and I’m glad I didn’t get more). We have been a major sponsor at Worlds in Louisville despite VEX not willing to be a customer of ours. My family and I have volunteered the at Worlds since 2016 and loved it. Hated that it didn’t happen this year in the same capacity.

You need to call Vex support 903-453-0802 and tell them what’s going on. The can walk you through the options.