VEX IQ Robots having problems running code

Hi everyone, any help would be much appreciated! I am a robotics teacher and this year, we’re getting back into using physical robots after using strictly virtual materials last year. We also received new computers in my lab.

I have installed new firmware using VEXos Utility to all robots and my students are trying to code their robots…We’re having issues with the robots running code. We’ve tried using Modkit VEX as well as Vexcode…the codes will download to the brain, but when my students try to run them, they start and then the brain beeps and the code stops.

This software all worked on these same robots previously before this year.

I have checked device info to make sure the motors work and the brains are updated. Any other ideas as to how I can problem solve this?

1 Like

Can you share a sample program you are having trouble with?

Did you try any of the sample programs available in VEXcode?

1 Like

It’s literally as simple as move forward 25 in. turn right 180 degrees drive forward 12 in

I have not tried a sample code, I will have them try that tomorrow.

I’m just thinking it has to be hardware related as it didn’t work with both vexcode and modkit

It would still be really useful to see the actual program. As simple as the programs may be, it doesn’t sound like a hardware issue.

I will post the program in a bit once my students arrive…it also looks like several robots are working when we run the code while the students hold the robot, but once they put it on the ground, then the code will start and then immediately stop or start working and then stop once making contact with something else

I think we actually figured out it’s battery issues. These batteries are about 4 years old and with not being touched in so long, I think they’re holding too little power to make the robots perform :frowning: