Vex IQ Tele op download issue.

Hello, my name is Ray, and I am relatively new to Vex IQ. I use Robot C Graphical to program all of my Vex devices, but I am having an issue with two of my IQ’s while downloading a teleop program. All of the firmware is up to date, the controller is tethered to brain, and brain is tethered to the computer during the process of downloading the teleop program. The issue is that when the program is downloaded to the brick, it does not register under the teleop folder;​ but is shown under the autonomous one. The program does not work at all when this happens, and I have no idea how to fix it. Any suggestions? (Possibly a factory reset?):mad:

In RobotC, there is a menu Robot->VEX IQ Controller Mode, where you have to switch to “Teleop”. Then compile and upload the program and it should work.

I have tried your suggestion, but it is still downloading into the autonomous window. Any other suggestions?

Are you sure it’s not going to both the Teleop and Autonomous folders? The newer versions that I have used behave that way. It will start the auton version automatically when downloaded, but you should be able to kill it and go back to the Teleop folder, open the Teleop folder where you will see the teleop version of your program.

If that doesn’t work then you might want to try re-downloading the RobotC firmware onto the brain.

Try making sure that you have the VEX IQ brain highlighted on Teleop before you download… that should get it into the right menu on the brain… otherwise ours was going into both auto and tele and the auto was starting directly after download

I am having the same problem. However, when I run the teleop…the program runs I can still control it, but since the program is running everything is jerky.
I’m new to programming…not sure what’s going on.

I am having the same problem. I have tried all the suggestions which have been posted, but it always saves into Auto Pgms and not TeleOp. When I download, the Debug dialog box comes up automatically. If I leave the controller tethered to the brain after downloading, and the brain tethered to the laptop, and start Debug, then the controller will control the robot. As soon as I untether, or stop Debug, nothing. Anyone got any ideas what to do?


What do you mean “… nothing.”?

From what you said, everything works fine when the brain is tethered to the remote, but stops working when you untether, right?

Sounds like you need to make sure the radios are completely plugged in. Check both the remote and the brain.


I was having a similar problem except it was not able to download to the physical robot, it wouldn’t even give me the option. It forced me to go virtual worlds. Similar problem maybe?

is not a thing I can do… problem there?

Also try re downloading the graphical version, I had to delete it and re-download when that happened to me

What is the status of your ‘Help -> Manage Licenses’ menu in the ROBOTC application? From the sounds of things, you may only have a Virtual Worlds license installed and not a ROBOTC license; the Virtual Worlds license will allow you to download the program to a Virtual Worlds environment, while a ROBOTC license will allow you to download the program to a physical robot.

I thought Steve’s radio suggestion made sense, but no. I’ve tried it and it’s just the same. What I mean by ‘nothing’ is there is no response at all from the robot when I use any of the controls on the controller although both are switched on and the lights are green. It’s not exactly that it works when tethered: it works while still tethered immediately after download if I start Debug. Otherwise not. Could it be that when I do that, the robot is getting the program from the computer rather than from its own brain? In which case, my problem is the one mentioned originally by Ray, that it is downloading to Autonomous not Teleop, even though I highlight teleop on the robot, and choose teleop in the Controller mode on the software.

Are the green lights flashing on the remote and the robot? That would indicate that they are connected.

I did have the license for it, still it won’t let me

I tried pairing the robot and the controller again. After I removed the tether cable, the lights are solid green, not flashing. There is no radio link icon, and no searching icon, and when I look in system info, radio data and signal are 0%. However, the radio links are definitely fully inserted in their slots. This is a new robot. Is there something I need to do to activate the radio modules?

Bridget, it sounds like a problem with the radios. You should contact VEX Tech support directly.

Thank you.

Have you tried using a fresh cable or seeing if there is something in the post blocking it? Lint has previously gotten into mine and prevented it from working