Vex iq "teleop" code downloading to autonomous section on brain.

I am trying to download code that I wrote in RobotC 4.0 to my brain, but it always downloads to the autonomous section on the brain. The firmware is up to date, and Robot -> Vex IQ Controller mode is set to Teleop. I also have tried making sure that “Teleop Pgms” is selected when downloading.

The code always ends up under the autonomous programs on the brain, not under the teleop section, where it should be. I am asking for help to get my code downloaded to the Teleop section on the brain.

I can help with this one as a local team in my area ran into this issue over the weekend. One of your radios is not working (probably the one in the brain/cpu). Make sure the radio is all of the way in. If it is, replace it with another ratio.

You can verify that the code is available by also tethering the joystick to the brain and bypassing the radio altogether.

I will try your suggestion. Thanks for responding so quickly

I installed new radio modules on the robot’s controller and brain, and followed the pairing instructions in the Vex IQ RobotC User Guide on page 9 (“Initial Wireless Setup”). The pairing failed. How do I bypass the radio?

Less important question: The driver control section on the brain is confusing. The two joysticks control motor port 1 and motor port 6, with simple code that does not change. Do you know if this “Driver Control” section a built-in function on the Vex IQ Brains?

I’m having a similar problem. My Controller Program downloads in both TeleOp and Auto. It works fine when i’m in TeleOp, but I don’t know how to make it not also show up in the Auto menu. This is a new issue as of the past week. My program is selected to be TeleOp.

I fixed the problem. You have to remove the battery and the brain’s controller module. Then, you have to hold down the reset button at the same time you insert the radio module. Make sure that the reset button is actually being pressed. When downloading, make sure to have the brain selected on the TeleOp menu. This worked for me and made me very happy.

I tried this today and it is still downloading the program to both TeleOp and Auto. They work fine in TeleOps, but I don’t want them to be in the way in Auto Pgms. Using RobotC.

Thanks for the help.