Vex Joystick Doesn't Respond to Program

Hi, was wondering if anyone else had the same problem with their joystick. The joystick connects to the robot after code is downloaded but the joystick does not respond to the downloaded code. All lights are green. Downloaded all new firmware. Calibrated joystick. Power cycled everything. Tried multiple cortexes. Tried multiple ports. Tried multiple joysticks. Tried debugging. Nothing seems to work. Before only the second channel on controller worked but it had stopped working after firmware was updated. Yesterday everything worked and nothing was changed in the code. Our sister team had the same issue with the same exact joystick button. If anyone else had the same problem and fixed it or if you could offer any insight it would be greatly appreciated.

We had controller issues at our last competition, turned out to be a coding issue. If you posted your code, someone could help see if something’s wrong.

Did you redownload your code after the firmware update? I haven’t used RobotC in a while but if I recall correctly the update wipes the cortex.

If that doesn’t work try making a blank program just start a motor or something when a button is pressed to verify whether or not its your code. Something like:

task main() {
    while (true) {

        motor[port2] = vexRT[Btn7U] * 100;


The syntax might be a bit off but you get the idea.

@Easton @ZachDaChampion I think it is the update. I just found out most other teams in my area are having the same problem. The people around my area are warning not to update the cortex because there is something wrong with the update. The tournament tomorrow I am going to is offering help with the situation. I for now am trying to find an old version of the cortex software and am using an old cortex that isn’t updated. Thank you for the help; it is greatly appreciated