VEX motor 393 not reversing

Hi, I have been having issues with my 393 motors on port one and ten not working in reverse. It is not limited to those motors either, as I have tried multiple motors with no different results. I have recalibrated the joysticks, and they do put out a negative signal when pushed down. Please take a look at my code attached below. Thank you, your help is greatly appreciated.

task main()
while(1 == 1)
// right motor //
motor[port1] = vexRT[Ch2];
// left motor //
motor[port10] = vexRT[Ch3]*-1;
//first motor for lift//
motor[port6] = vexRT[Btn6U]*126;
motor[port6] = -vexRT[Btn6D]*126;
// second motor for lift //
motor[port7] = vexRT[Btn6U]*126;
motor[port7] = -vexRT[Btn6D]*126;
// chain motor//
motor[port9] = vexRT[Btn5U]126;
motor[port9] = vexRT[Btn5D]


Try running this code, below. This should move the motor forward for 2 seconds, then backwards for two seconds. This will let us know if the issue is with the code or something else (potentially with a damaged H-bridge on the Cortex).

task main()

motor[port1] = 50;
motor[port10] = 50;

motor[port1] = -50;
motor[port10] = -50;

Hey, I tried running the code. Port one moved forward(port 10 didn’t), and then port 10 moved backwards(port one didn’t).


I switched ports 1 and 10 to ports two and eight and it worked. Thanks for the help, I appreciate it.