Vex offroad Truck - Left and right not working

So we set up the off-road truck today. It goes forward and backwards no problem but will not steer left and right.

The front motor works, when we try to play with setups the front wheels will jitter left and right, but nothing more.

Help and thank you!

1 Like

Solid wheels often lead to problems with turning, try replacing the front two or all four wheels with vex omnidirectional wheels or mecanum wheels

Im assuming this is vex edr, if not then im afraid I can’t help you!

1 Like

This is a common problem with this kit.

  1. Verify that the turn sensor on the front is positioned correctly. When the truck starts up, the front wheels will turn left then right then back to center.
  2. Do you have the latest version of the software? The hexbug software needs to be on the latest version.

If you do the above things then you should call VEX/Hexbug support during working hours.

I’ve had three of these kits and the brains ended up replaced in two of them.

4 Likes

Is there any way to see if it’s ok without having to undo the whole truck?

Hi Catalina!

Welcome to VEXIQ and HEXBUGS

Sadly, that sensor is DEEP inside the engine area. You don’t need to take apart the entire truck but you will need to take the front apart. As I remember, taking the hood off and going that way was slightly easier than taking the bottom off.

In either direction you are looking at about 1/2 hour of disassembly/assembly time. I would take it apart, verify the the placement and then try it outside of the truck. That way if they decide you need a new sensor that you are not taking it apart AGAIN.

Good luck!
Foster

4 Likes

Just to tack on to this, this is referring to step 26.

image

The orange arrow on the sensor should be pointing at 12 o’clock as it is assembled.

7 Likes

@Catalina976 – Just checking back to see if you made any progress on this

One last reply to see if you were able to make your robot drive. What was the fix?