Vex Pilot App is made for older version of Android


I bought the “VEX Robotics Offroad Truck” and only then figured out that the “Vex Pilot” application is “made for older version of Android”? I tried Android 10 and 12 and neither of them worked.

Would it be possible to get any support for this? How can I steer this truck?

PS. I wasn’t sure which category should this be put into.

Thanks in advance

You should contact to get this sorted out.

1 Like

Hi, I’m having this same issue, also trying to connect the Off Road Truck. The app is working on my old android phone but doesn’t connect. On a different phone, Android version is newer and app unavailable.

Would be great to see this app updated! Thanks

I reached out to Vex support on the 9th of April, but they were busy organizing VEX World championships.

I pinged another message on the 21st of May but got no response.

Hopefully, they will have some capacity to rework that soon

You will need to contact or call their phone 903-453-0802.

They are closed on Monday so you’ll need to wait until Tuesday.

This will be an ongoing problem with lots of things that use phones / tablets for controllers. I have a spiffy track robot with an arm and a camera that no longer gets software support. So I keep an ancient iPad around to run it.


Is that a Gomer Foster?

Like Gomer, but it was sold by Sharperimage. The newer ones come with a remote control, the original one used an iPad. Not sure I think I got it in 2013-14?