Vex RobotC programming

I just installed the latest version of RobotC for Cortex on my computer. Along with that, I recently installed the CPU Master firmware and a whole bunch of other firmwares on to my cortex and joystick, i then tried to drive the robot after but the robot would not respond to any of my commands from the joystick. (Note: This is plugged in through the USB male A-A cable)

Lights on Cortex:
Robot: Green that blinks every 2 seconds (mississippis)
VexNet: Nothing
Game: Fast green blink

Lights on Joystick:
Joystick: Solid Green
Robot: Green that blinks every 2 seconds (mississippis)
VexNet: Solid Green
Game: Nothing

Anything i can do?? :confused:

Thanks!!! :slight_smile:

P.S. It seems to always staart up with a demo program.

Hi Sean,

If you haven’t already, you will also need to download a program to your robot that tells it what to do with the joystick signals. If you’re looking for a program that emulates the default firmware, you can find one by going to File > Open Sample Program > Advanced.

I’d recommend watching some of the tutorial videos we have in the VEX Cortex Video Trainer, specifically the Remote Control section:

I tried it, now all the lights are green except for game on the cortex,it still wont respond. I have tried all sample programs that has to do with the joystick and cortex, i also tried re-tethering but nothing works! :mad:

Hi Sean,

It might help if you told me a little about your robot. For example, most of the sample programs are written to turn on motors plugged in to ports 2 and 3. If you’re not using those ports, your robot wouldn’t move.