VEX V5 battery Not Charging or Displaying Lights

I have a V5 battery that was used once. It was plugged in to be charged but when I came back to it an hour later the battery wasn’t responding. It’s not charging and it doesn’t display either red or green lights. I plugged it in, hit the reset button and waited for another hour, but nothing is happening. Is it defective? If so, can I send it back to VEX and get a new one?

ok, I know you probably checked this, but I have to be sure, does the outlet you plugged it into work? also, does the charger work on other batteries?

if the answer to both of these is yes, then i would contact vex support at support@vex.com

Sounds defective. Find your receipt details and visit rma.vex.com on how to submit it for repair.

You can also try pressing the battery reset button located here using a paper clip. Then trying to plug in the battery again.
image

2 Likes

(Disclosure: this happened to one of the team at my school, but I don’t fully understand it.) it might be that’s the battery needs to be reset via computer or the firmware (yes, I know this sounds weird) needs to be updated.

1 Like

@jpearman has repeatedly mentioned it is a bad idea to press the reset button, but rather use Battery Medic and battery troubleshooting steps in kb.vex.com

If those fail, definitely contact VEX Support.

7 Likes

I’m not sure how I would go about doing this. Any more details you can provide?

I’ve got two batteries outside of warranty that will not turn on or do anything. I’ve tried everything I’ve found that’s been recommended either officially or unofficially on the forums.

I tried to submit an RMA for them but VEX Support told me they wouldn’t take them because the repair cost is more than their purchase cost so I’m back to dead in the water.

you would hook it up to the computer. After that, I am at a loss. I think you would go to the vex website on batteries.

You cannot hook up V5 batteries to a computer, all firmware updates are handled by the V5 brain.

Then there’s really nothing you can do (if you have already tried the “last resort” reset button), take them to a recycling center.

How old are these batteries ? Were they left unused for any significant period of time ?

9 Likes

Yeah I’ve tried the button and they didn’t respond at all. They sat for the summer months but that’s it. Probably one of our original v5 batteries we purchased.

I’ve got a third battery that shows all good in every which way including battery medic but about a minute into using it and it will claim to be dead until it’s plugged back in. I can at least use that one while it’s plugged in to run a field control brain.

Thank you for the response!

1 Like

I tried the medic firmware, but since battery is dead it won’t power on the brain to even try an update/reset. I also tried the reset button on the battery, but still nothing. I’m thinking its got to be defective.

My school purchased these batteries so I have no idea when this particular battery was purchased but my guess is that it had to be within the past year. I only started using them on August 16th, so I really hope VEX will replace the battery without charging for repair. I guess I will have to fill out the RMA form.