Vex V5 Battery Unable to Charge?

Hey there, I have recently waited an entire month for our team’s V5 kit plus field elements to arrive, and what I’ve discovered after the wait is that our battery doesn’t work. It displays as ‘charging’ when plugged in but after 3 hours the ‘charging’ blinking green light turns into the slow, flashing ‘internal error’ red light. Do you guys have any solutions to this? I’ve tried resetting, the firmware is up to date (1.0.7), and this is our only V5 battery. Please, if you guys have any help that would be much appreciated, we are getting desperate.

run the battery medic from the V5 firmware update utility and let me know the results.

4 Likes

Do you happen to be using the charger you got from the kit? I had an issue similar to this and it turns out I was using the charger for the legacy remote

Charger for the legacy remote? If you could clarify this a bit that would be really helpful, because I’m using the only charger I was given.

Once I get home I’ll be sure to do that, stay tuned.

There are rechargeable batteries for the legacy controller.
There is a charger for those batteries in the form of a docking station.
The plug and wire is not part of the charging station and must be plugged in separately.
It looks very similar to the v5 charger
I’ll send pictures once I get home if you need me to

I’m pretty sure I’m not using that, I took the kit charger out of the box yesterday and tried it to no avail. I’ve called support and they’re trying to send me a new battery, but I want to see if there’s any way I can salvage this. Thanks for your concern, though.

2 Likes