VEX V5 controller on red connect screen and frozen there

Our controller screen is red with a symbol that says to connect the controller to the brain. When we connect it to the brain it asks us to update, but after we do the controller screen doesn’t change. All our firmware is up to date and we tried resetting the controller and battery.

is the light on your V5 radio flashing? you could have a bad radio/radio cable
That happened to my team once

The controller was plugged into the brain, so that should not have mattered.

perhaps the cable, port on the brain or port on the controller are bad so that the controller doesn’t register as plugged into the brain.

We have tried multiple cables

We tried using a cable that worked for motors

and you tried resetting the controller with the embedded button in the back?


Yes we did try using the reset button on the controller

Is your vexcode up to date? im a little out of ideas on how to fix that.
Is everything charged?

1 Like

You brain and controller need to be updated, just hook it up to the brain and update it off of vex code pro

1 Like

Did it it work @6096B?

1 Like