VEX Via Issues

@Powerbelly @dbenderpt

Every time i try to open Division 1 of your competition on VEX Via, it crashes the app. I am able to open the team list for other competitions, so i am not sure what is going on. I have restarted the phone, and next thing i will try is uninstalling the app and reinstalling, but if you could test it as well and determine if it is just me who is having the issue, i would appreciate it.

Uninstalled and re-installed the app. Same issue.

Well, it’s not just you. Me and Thomas (491) are having the same issue. Maybe it’s just something with the event itself? Other events are working fine.

@Joseph W(182 C) tested it for me too, it seems to be just android that crashes. The iOS version loaded fine for people on our team.

That is good info, i am also on Android.

Looking at random events, the Niles Township District 219 event will crash it too.

Alright, i had just tried random events until i found one that was up and it did not crash. So, it is not just one event. That means it is probably an issue with the app.

I will post it into the official Tech Support thread.

Thanks for reporting this. We’ll take a look at it and get a fix out as soon as possible.

As a few mentioned earlier, I just tried it on iOS and haven’t had any issues in the areas explained thus far. I’m pretty sure there is not much we can do as an Event Partner besides make VEX Via available. There obviously shouldn’t be a match schedule available until tomorrow morning after all teams are checked in, so only the teams should show up currently. @Powerbelly can elaborate because he’s the actual event partner and has more experience and insight than I do. We’re very excited to see you here tomorrow for the event!

Our team uses the app a lot at competitions and really appreciate the service it provides! Thank you for looking into it!

If it is multiple competitions having the same issue, i doubt it is a problem on your end. We look forward to being there!

Is this the event in question?

If so it should be working again in VEX via at this point. The issue appears to happen when an event publishes rankings before having teams or matches, so that’s why it only affects some events. It should also clear on its own once non-empty rankings are published.

We’ll have an app update out soon and in the meantime we’ll attempt to mitigate this on the server side.

That is the event in question. Thanks for the quick turnaround.

I just published a new version of VEX via for Android that fixes it on the app side. Thanks for alerting us to the issue and let us know if you see any other problems.

I was not having any issues last night (probably after @Dave Flowerday was working on the back end). I updated the app anyway and it still looks good. I am using an Android.

Thank you all!!! You know you have great service when a problem gets fixed the day it’s presented :slight_smile:

@Dave Flowerday So Vex Via worked until lunch today, but after that, it never updated again. Robotevents was also not updating. It still is not up to date. It is the same tourney as mentioned earlier. The issue is probably somewhere between TM and Robot Events. They even tried restarting TM after the qualification rounds hoping it would update, but no joy. Thought you would want to know. Thanks for your hard work.

There was a problem with the server in the early afternoon. Once we realized via was sluggish at best, we fixed the issue and got it back up and running by late afternoon. Sorry for the inconvenience.

It never got back to working for the tournament where we were. In fact, the robotevents page still has not updated and I know the EP has done everything he can on his end.

@blatwell That event has not published anything since just after 4pm on Saturday, which was right before we added additional server capacity to address the loading issue.

When the EP uploads their final results they will appear in the app.