VEX Visual Studio Code Extension

Thanks. New account without spaces works!!

There is a reliable way to rename an account properly but it requires Admin access and might not be worth the trouble:

  1. reboot and login as Admin (might need to enable first - school laptops might be locked)

  2. Win+R then type and run netplwiz and change user name in there (ex. Bob Joe to BobJoe)

  3. Open a command box and do

cd c:\users
hit Enter
ren “Bob Joe” BobJoe
hit Enter (need those double quotes)

  1. Click Start, type regedit, run it

go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

You need to click through all the profiles and find the one that says %systemroot%\system32\config\Bob Joe in the ProfileImagePath

When you find it, double-click ProfileImagePath and modify value to say BobJoe at the end.


PS. If any of the above looks foreign, please skip and just make a new profile or ask whoever’s in charge to do so because you can really mangle your Windows installation with all this…


As Halen said, the next version of the extension due out in a few days will handle accounts with spaces, it was just something that got missed.


@holbrook: I got it to work seamlessly on Ubuntu 20.04 as well but no serial comms. Were you able to hook up a brain to it? Sorry I’m causing trouble in this thread, just very excited about this extension and all the new opportunities… If it worked for you, then I’ll poke around my serial/USB settings. Thanks.

Nope, sorry, didn’t have a brain on hand to try it at the time (nor do I right now).

On Ubuntu 20.04 device detection and serial coms will work, but you need to add a udev rule that allows each device(V5 Brain, V5 Controller …) to have permissions when connected to your computer.

The plan is to eventually document a generic version of this procedure, but it is lower priority.


The minimum udev rule you will need is.

# allow user rw access to serial ports

Worked! Thank you @hphillips @jpearman

Ah, I see now. I had actually tried what you suggested (before you suggested it), but I had only done the step with Regedit, assuming that regedit would change the name of the user folder for me… I had found out very painfully after I restarted that this was not the case →


1 Like

I’ve had a few teams who are using M1 Macs or Intel Macs download VS Code and when they try to install the extension it just continually hangs and doesn’t complete the extension. Is there a reason this occurs?

Does this happen when you install other extensions?

I have a M1 Mac Monetary and I have downloaded the VS Code exetntion. So it does work.

1 Like

So just to clarify, did the extension hang during installation, or did it successfully install and then hang once the extension started to run?

If the VEX Extension installed correctly, it should appear in the installed list as shown below. You should also see the VEX side bar menu icon.

If the extension is installed and running then it may be the runtime bug we found, see below:

I should be releasing a new version of the extension in the next few days that will address this problem.

If you continue to have problems, DM me and we can dig into the issue further.


It was hanging during the installation. We did not encounter the case where the VEX extension icon showed on the side bar menu.

Set up a GitHub repo and enabled all the git stuff to work with VS Code. Set up 2 laptops. Cloned the repo. Started playing with changes, commits pushes and pulls to understand the process. Placed a *.json line in every .gitignore file available. However, every time we do a pull from the online repo, it brings every project file into the laptop’s directory, including a settings.json file that is inside a .vscode folder. That file has a line “python.analysis.stubPath” that lists a local directory on the laptop which includes a user path. If that path is incorrect VS Code says the project is not a VEX Extension compatible one. Closing that project and reopening it fixes that by changing the settings.json file appropriately but then versioning control screams that there is a change that needs to be commited and an annoying loop starts. How do we handle that?

EDIT: apologies for changing the post twice.

files inside the .vscode folder

yea, that’s specific to the laptop (or rather vscode workspace) used, just don’t commit that to the repo.


Thanks. I think our issue is related to the fact that if you add a file to .gitignore after you added the whole project to git, your gitignore setting is… ignored. Man, git is like an entire new world. You can do it this way or that way or the other way. But don’t bother because you will be ignored. Time for some deep Google dive. “Read the game manual” and “search the forum before posting” - not working.

yes, you need to un-track the file. I use a git UI called tower, they make it reasonably easy.


Thanks again. Got all deep in git commands and missed your (super fast as usual) answer. Will definitely check out Tower.

Ended up doing all that by hand with this CLI command:

git update-index --assume-unchanged [file]

where file is every .json that we wanted out of the index.

EDIT and the commands from your tutorial linked above which re-do the index:

git rm -r --cached .
git add .
git commit -m "Fix ignore unignored ignore files for good"
1 Like

I installed the VEX Visual Studio Code extension and already had all of the other extensions pre-installed. An issue I am facing is that that the header file vex.h is not found after being included in main.cpp, and it also says (weirdly) that math.h is not found either in vex.h itself. What is the issue and how should it be fixed?

It probably has to do with the c_cpp_properties.json in the .vscode folder.
I will dm you so we can work through this.