VEX Wireless Programming

Whenever I’ve tried using the wireless programming kit provided by VEX, we always end up with bad experiences – RobotC starts lagging and crashing, the same value gives different results, and sometimes the program just won’t download.

Does anyone else have these same issues as well? And has anyone found a solution to them?

I’m not sure the specific problem for your situation, but from what you are describing…I think it’s something wrong with your connection.
What I will do to figure out what is wrong:

  1. make sure your cortex is pared up with your joystick by connecting it directly with the orange cable
  • check if the firmware are the same version
  1. check the debugger window //when it’s directly connected
  • to check it’s not the cortex’s problem
  1. make sure you can fully control your robot before connecting the programming cable to the joystick
  • like the LED lights on the cortex and joystick
    4…make sure you press start (sometimes people can be careless XD

The same value giving different results may be a problem with your code. If sensors aren’t reset in the right places they may not reset. My team uses SensorValue(name) = 0; to reset our sensors and it works quite well. We usually have this at the very beginning of autonomous. As for robotC crashing and lagging my team has never had a problem with this. It slows down a little but is always responsive.

So the crashing can be solved by enable message logging. I have this issue on my computer (not all computers have ever issue but those that do really notice). Also you can unplug and plug back in USB cable to recover ROBOTC.