VEX World Championship - Firmware Update

The VEX Robotics technical support team has identified an issue that some competition teams are experiencing in which the Cortex Microcontroller is unable to resume VEXnet link after a Microcontroller reset.

To help teams avoid this phenomenon at the VEX Robotics Competition World Championship, we are encouraging all teams to test and update to a new firmware version. This version is compatible with existing versions of easyC and ROBOTC, and does not require users to modify their code at all.

Go here for more information, and the new firmware download:
http://www.vexrobotics.com/firmware_update

Full announcement:
The VEX Robotics technical support team has identified an issue that some competition teams are experiencing in which the Cortex Microcontroller is unable to resume VEXnet link after a Microcontroller reset.

To help eliminate this issue at the VEX Robotics World Championship we are releasing a special version of the VEX Firmware, specifically for World Championship teams (3.21_Worlds). This firmware version modifies the Cortex re-initialization to help the VEXnet link reconnect in the event of a reset (i.e. caused by VEXnet Key “jostling”, power interruption, battery brownout, or static).

We know that competition teams dislike updating firmware so close to an event, so we are publishing this update in the hopes that teams will have a chance to test it “at home” before coming to VEX Worlds. If you’re comfortable with the new version, we strongly urge you to use it at the World Championship to help prevent potential problems related to a Cortex reset.

This firmware only updates a “back end” relinking protocol and it does not affect anything related to robot performance – you don’t need to tweak your autonomous mode, or anything like that.

Visit the VEX Forum thread on this firmware release for more discussions and to post any questions or concerns.

Does vex still recommend that we use the vex worlds firmware if we are using easy c or should we switch over to the newest version of the easy c firmware that was released today (3/28/12) ?

is any update on which firmware to use for worlds?

VEX Robotics recommends all VEX World Championship teams use the 3.21_worlds firmware. This is a special firmware, which is not being pushed to the general VEX user base (which consists of a large number of non-competition users).

-John

ok. the only reason i was confused was that easy c released a new version after vex did. thanks for clarifying!

Intelitek did release a new version, 4.1.0.3. This version has the same master code as the previous EasyC version (4.1.0.1). They had initially suggested using the included firmware but amended this a couple of hours later. Here is the post from another thread.

For those of us who aren’t programming experts, how does one download this firmware from the computer into the robot? The file we downloaded into our computer is not in our ROBOTC download menu, and when we tried running the file “setup,” the computer gave us an error message.

Before someone else asks, what did the error message say?

//Andrew

  1. Download the folder from Vex
  2. Put the folder in an easily accesible location during the install process (e.g. Desktop or Downloads)
  3. Go into RobotC and scroll down to Master Code and select “choose file”
  4. Find the folder with the firmware inside
  5. Select the appropriate firmware (the one labeled Master Code v3_21.BIN or something similar)
  6. Download to Cortex

Actually, the setup file worked, and it gave us a lot of files. When we try to run the file VEXnetUpgrade.exe, the error message says this:

Component ‘MSCOMCTL.OCX’ or on of its dependencies not correctly registered: a file is missing or invalid

Don’t run the executable. Pick the .BIN files from the folder in RobotC as needed to download to the Cortex and Joystick.

EDIT: I may be unsure of what step you are on. I can’t check the process right now so I apologize if I’m wrong.

By your list, I am having trouble with step 3. Under “Download Firmware,” and “Master CPU Firmware,” the only options we have are “Standard File” and “Last File Downloaded.” There is no “Select File” option.

Wow, I take an hour off for my Easter turkey dinner and everyone goes crazy :slight_smile:

Two ways to update the firmware.

  1. Use the VEXnet firmware upgrade utility, if you are getting the “MSCOMCTL.OCX” error then this often happens if you are trying to run the application under windows 7 64bit, if this happens try running the app in 32bit compatibility mode. If you already have “normal” 3.21 loaded then the vexnet upgrade utility will tell you that you that you are up to date, if that happens then power the cortex whilst pushing the config switch with a paper clip or similar, that will put the cortex into boot mode and allow you to download.

  2. Use ROBOTC to download the file, to do this you need to enable super-user menu level, that’s why you only see the two options. Then download the file C:\Program Files\VEXnet Firmware Upgrade\CORTEX_V3_21_Worlds.BIN (under XP, will be different under Win 7)

We have Widows 7 Starter, 32-bit.

How does one enable super-user menu level?

Under the window menu.

[ATTACH]5674[/ATTACH]
robotc_super_user.jpg

Thank you!

254 has been encountering some problems with the new firmware and I was just wondering if anyone else has experience a similar issue. When VEXnet becomes disconnected for any number of odd reasons (i.e. keys got too hot, knocked loose, or power to the controller is interrupted) the robot does not simply stop responding; rather, the motors continue as they were the moment connection was lost. For example, if you are turning your robot and raising your arm and connection is lost, the robot starts doing 360’s and attempts to raise the arm to the point of breaking. Connection cannot be regained without a power cycle. This error has been encountered by two of our teams so far. Has anyone else encountered this or can anyone offer suggestions?

We are programming with the latest version of robotC and the world championship firmware.

edit:
We have tried reverting to the past firmware and this eliminates the issue completely. This is why we suspect it to be a firmware problem.

I got a report from my team that they had seen similar behavior when using Rob0t C 3.05 and Master firmware 3.20. I was not at the meeting so I don’t have many details. When I followed up with them I was told they had just changed keys as they were getting hot, and then the robot went out of control during autonomous (I’m not sure they knew if they lost link) Swapping keys back resolved the problem. Since they were on the standard firmware 3.20 which comes with Robot C 3.05 The problem may not be just with the new worlds version. When your teams experienced the problem where the Keys hot? had they been in use for a while?

Cheers Kb

Can anyone explain how to install this update on easy C?