VEXcode forgets that make exists

Occasionally, around once every few hours, VexCode will just stop being able to compile, instead giving this error in the Output area:

'make' is not recognized as an internal or external command,
operable program or batch file.
[error]: make process closed with exit code : 1

This can be fixed by running the installer again and choosing the repair installation button, but this can take as long as 15 minutes to do and really takes a lot of time out of coding sessions.

1 Like

Im pretty sure this got fixed in Preview 3. The temporary fix for preview 2 was to just restart vexcode.

1 Like

When we’ve seen this error, just restarting VEXcode brings it back to life.

edit- Sniped!

yes, as far as we know it has been fixed in preview 3.
There should not have been any need to reinstall VEXcode, unless you have found a different issue, please update and let us know.

I updated last night and just had the issue a few minutes ago, It happened immediately after doing a firmware update but only happened on the first brain I updated on.

To clarify,
VEXcode preview 3 should have fixed the make issue, this is independent of whether you had updated the V5 brain to vexos V1.0.7 which was also released yesterday. Can you confirm that preview 3 is working for you in respect to the “make” issue that we had before

1 Like

Updating fixed it. Thanks.

Preview 3 still has this issue. Ive been working in it for a few days and have had this issue and my second team just had this issue today on preview 3.

I’m also having this issue with vex code. I just downloaded vex code yesterday so have no clue what the issue is. I tried restarting vex code and this did not fix the issue. I’m getting both the error listed and: [error]: make process closed with exit code : 2 Any tips? Thanks

i still have the issue with the Preview 3 !!! the issue still remains even if i have used the repair installation for many times.
by the way, each time during the repair installation program, there will be an error says “the installation of Microsoft Visual C++ 2013 Redistributable Package appears to have failed” . but after i download and install the Microsoft Visual C++ 2013 Redistributable Package from Microsoft, the error is still here.
i do not know if there is any relations between the two issues, i wish someone would tell me what should i do now.

i am using the surface pro 5 with Windows 10-1903

The same problem is happening to me. I uninstalled and reinstalled and in gives me the same error. I mentioned it in this thread but couldn’t find a solution.

[Build Error when Trying to Download Code]

1 Like

I am now getting this “make process closed with exit code : 2” error on VEXCode Text v0.9 as well and cannot download the program. Any suggestions?

Does it have anything to do with Make disappearing?

What do you mean? The build folder is still in my project folder.

Open a new thread and explain your exact problem. The problem in this thread’s OP has been addressed.

1 Like