VexCode IQ Blocks - Robot is not following the program, going in circles

I have students programming the exact same code using different computers; however, one robot works, the other starts moving forward then spins. I’ve tried repairing the problem software, clearing out the program and restarting a new file, taking out the battery, double check the robots. I’m at a loss of what to do. I tried having them download a program from another group and sometimes this got it to work but not always. What am I missing or what should I be doing? Thank you!

May help to share a copy of the program as a pdf, that way we can look at the specifics of the code that is causing the odd behavior.

You can export it as a pdf by clicking share and attaching it here:
image

1 Like

It says because I’m a new user it will not let me attach code.

In that case, you should be able to take a screenshot of your code and include the image in a post.

Here’s a screenshot of their code they sent by Direct Message:

image


And the programs via email:
TinCan.iqblocks (15.2 KB)
VEXcode Project maze 444.iqblocks (14.9 KB)


I dont’ see anything immediately wrong that would cause the robot to go into circles, maybe @tfriez will notice something there.

1 Like