VEXcode IQ Blocks Version 1.0.7 Release

We are happy to release version 1.0.7 of VEXcode IQ Blocks. It can be downloaded here:

New for this version:

  • Added feature for user created blocks - “My Blocks”
  • Added feature for users to disable/enable blocks via the right-click / long-press context menu
  • Added feature for 4-Motor Drivetrain configurations

Bug Fixes

  • Resolved an issue where the Feedback Tool may block certain types of email addresses from being accepted
  • Resolved an issue where the IQ Brain may appear not connected to the computer when VEXcode IQ Blocks was not connected to the Internet
  • Resolved an issue where the default variable in new projects was named “My Variable” - Now fixed to be named “myVariable”
  • Improved error handling when a Vision Sensor signatures are not assigned
  • Improved error handling when a Vision Sensor signatures are named with certain letters
  • [Windows] Resolved an issue where the compiler would fail after multiple downloads in a single session
  • Added missing help information for the controller enable/disable block
  • [iOS/Android] Resolved issue related to users receiving a “3 second timeout” error when using IQ Smart Radios in a noisy RF environment
  • [iOS/Android] Resolved issue related to users receiving corrupted downloads when using IQ Smart Radios in a noisy RF environment
  • Resolved an issue where the “Set Gyro Heading” block not working as expected when used with events
  • Added optimizations to generated code to improve memory usage in IQ
  • Resolved an issue where the Vision Sensor may not update its configuration at the start of a project
  • Improved example projects to remove unused devices from the project’s configuration

Some known issues include:

  • Blocks do not automatically update when device / direction names change in the Devices window
  • Share functionality is not yet supported on iPad/Android
  • Recent Projects is not yet supported on ChromeOS
  • Projects will not download on iPad/Android if a VEX IQ Controller with a Smart Radio installed is actively linked to a VEX IQ Brain
  • Tutorial videos cannot be played in “full screen” mode on ChromeOS
  • When installing on Windows 7, you may receive a warning about unsigned VEX IQ drivers. Users will need to select “Install this driver software anyways” to proceed
  • Interacting with notes on iOS devices may cause problems with responsiveness. If the workspace is not responsive after interacting with notes, select a Category from the Toolbox to restore the workspace
  • Using the “Share” button to generate a PDF of the project does not print the content of project notes (yellow boxes)
  • My Blocks argument blocks may not appear disabled if you drag them straight from the definition block into any other block - however the block’s behavior is actually disabled
  • Feedback system is not working properly on iOS and is temporarily disabled

Just like normal, iOS and ChromeOS builds for this version may be delayed by a few days due to Apple / Google review processes. These will be published as soon as they are approved.

As always, we appreciate any user feedback. If you come across something that doesn’t seem right, please let us know below!

3 Likes

+10000000000000000

Much needed!

The My Blocks dosn’t have a “and don’t wait” option. Would the following be the difference between a blocking and non-blocking forward?

image

The weird names are because of:

image

2 Likes

You could pass a Boolean flag that had an if/else condition for “and don’t wait” optionality.

You can have parameter names be the same in each my block, you just can’t have the block labels AND parameter names be the same or else the compiler will get confused. We’re working on making more improvements to handle that situation as we move forward.

3 Likes

Of course, yes. Thanks!

2 Likes

I get the following error when I try to upgrade:
image
any suggestion on how to resolve?

in the new version , can we copy and paste blocks (from one program to another?)

thanks

Regarding the installer issue

  • Are you using the EXE installer or the MSI installer?
  • Do you already have a version of the application already installed?
  • Did you try restarting the computer?
  • Is this on a manged (school) computer?
1 Like

I just noticed a couple of interesting changes to the two motor drivetrain. The first is that now you can specify a track width when configuring the drivetrain. This is the width between the two wheels. I wonder what this is used for. I wonder if it might be a future option.

The other interesting change is that now you can configure the drivetrain without adding a gyro. This is interesting, because I thought they used the gyro to determine how far the bot had turned. Does this mean that now you can either used gyro information or motor information when turning?

And since I am on the subject, it is now possible to configure a 4 motor drivetrain. It seems of limited use to me, since all you can do is configure two left motors and two right motors. I know I would not find that useful. Now if you could configure 4 motors driving 4 meccanum wheels, now that would be something…

I was able to install the latest version on both my Ipad and my desktop PC. I have not attempted to run anything yet… Stay tuned!

1 Like
  • Are you using the EXE installer or the MSI installer?

I have a lower rev installed already. When I start the program, I get a prompt to update the SW to latest rev. When I first did the install of the initial version, I used the msi installer.

  • Do you already have a version of the application already installed?

yes

  • Did you try restarting the computer?

essentially the installation is not completed. The next time I start, I have the old rev running (even after restarting the computer)

  • Is this on a manged (school) computer?

home computer

I am tempted to uninstall and reinstall a fresh copy, but I am worried to have an install problem again and end up with nothing…

Thank you for the information.

The error you are encountering indicates that the installer is getting confused about what version is installer or is being installed and thinks that you are trying to install the same version again. Since this is the case, uninstalling the existing version should fix your problem this time, but I would like to try to understand what is causing the issue in the first place to prevent it in the future.

Do you remember how you originally installed the application?
Can you please tell me what version you are currently using? This can be found under File -> About
Can you tell me what version of Windows you are running?

2 Likes

Ok. Now I can see I am guilty of open mouth, insert foot. I think the drivetrain commands are supposed to use the wheel spacing to determine how far the bot has turned when the gyro is not used.

I tried it, and it did not seem to work. I tried turning 90 degrees, and the bot turned about 120. Changing the wheel spacing did not seem to have any effect. I changed from 160 mm to 200 mm wheels. It comes closer to turning the right amount, but it is still significantly off.

I believe I originally installed the 1st version with the msi installer back in September. But I had initially some issues with the microsoft .net library (if i recall correcty)… I think I was able to upgrade to a subsequent revision.
image
image

Using Windows 7

I have tried to update multiple times. Perhaps there are multiple copies of the installation files?

The issue was happening in the “registering products” phase.
I uninstalled and re-installed a fresh copy and it worked.

thanks!

My students are still having trouble with their code disappearing overnight after they save their work on their iPads. I have fund some instance to be user error but others are saving their work and it’s not there anymore when they open it. We are running the latest versions of both iOS and IQ Blocks.