VEXcode not working

I was having issues with vaiid Python Syntax not working on Robot Mesh, so I gave VEXcode a try.

I created a project for my Python Code.

When I click Download or Run Icon, unlike Robot Mesh where the process takes a few seconds, VEXcode returns instantly. Basically nothing happens.
No Error Reported, No code Downloaded.

Any idea?

I assume VEXcode is seeing the Brain OK, i.e. the Brain icon is green indicating the Brain is detected and the firmware up to date?
image

If so, does the most basic of programs work?

from vex import *
brain.screen.set_cursor(1,1)
brain.screen.print(“Hello World”)

1 Like

@Andy8Kahn - Please use the feedback tool within VEXcode after having this issue occur so we can take a look at the logs to understand what might be happening.

Thanks!

2 Likes

So I tried your code. I get the same exact error is before on the VEX Screen.
Sorry for not posting this earlier.

Error is:
"Traceback (most recemt call last);
File “userpy”, line 12, in
ImportError: module not found

image

can you post the Python code here, the error is implying you are perhaps importing a module that doesn’t exist.
and if it was just the three lines above, can you verify that the brain is running the latest firmware (1.0.12, go to devices screen) and that VEXcode is up to date (2.0.2-479)

2 Likes

from vex import *
brain.screen.set_cursor(1,1)
brain.screen.print(“Hello World”)

I’m working on the same project with Andy Khan.

We looked through vex code libraries and we could not find python code so maybe we are missing a library. if this correct, where should we get the library?

Look above for the code, we are just importing vex.

You don’t need any libraries, everything is in the Python VM that’s downloaded onto the brain by VEXcode. The V5 does the compilation from text to bytecode. You could force the VM to be re-downloaded by using “delete all programs” in settings on the V5 brain, but I’m not sure that’s the problem as the VM is running.

Have you tried one of the VEXcode Python examples and verified that that works (or just a new template program) ?

can you verify vexos and VEXcode versions for me ?

(and be careful, the code above has curly quotes rather than plain " and will throw a syntax error)

2 Likes