VEXCode Text - controller connections orange

My firmware is up-to-date on the brain and the controller. When I plug the USB cable into the computer and the controller I get a flashing orange controller symbol and the stacked blocks on the VEXCode text program. I am not able to download programs to the brain nor does any information appear when I click on the flashing orange controller. What can I do?

1 Like

The orange means that a controller is connected but that controller is not connected to a brain.

It seems as if your the brain is not connected. When you download code from the controller the controller is literally sending the code that it is receiving onto the brain through means of a wire or the radio. You can also download it directly from the brain.

Here are some things to check:
Is your brain on? Is your brain connected with the controller? Have you tried just plugging the brain in? Have you tried to restart the computer, or change the wire?

Just the obvious😁

The controller might also need an update, that was a solution we found.

Thank for the suggestion.

Brain is on and the controller is connected via smart cable and plugged in the computer via USB cable. Still not able to download programs and still have orange flashing icon. I have also tried using the VEXnet and still no connection.

By all indications the controller is updated. When I try to click on the flashing orange icon I cannot get any response or info.

Are you using the latest version of VEXos? I believe the controller got an update in the latest version.

Remote and brain are connect through Vexnet and through cable by themselves, individually. Yet, in trying to download a program through the usb that is plugged into the remote, no joy, orange flashing remote symbol on the program.

Did you try downloading straight through the brain? That will tell us if there is anything wrong with downloading.

One other thing, When I connect the usb cable directly to the brain, still no download symbol is available to push programs on to the brain. I have tried different ports on the computer, as well as different cables, the program does not recognize the brain. Also, tried different computers.

After trouble shooting all day, it appears the pc port on the brain is loose and pressure has to be applies upward for a connection to be made and to download any programs. Still cannot explain not being able to recognize the remote in the program. It may be the same issue.

When something like this happens it is usually not the device, but the wire itself. That is why so many of us want all devices to switch to USB-C, because it doesn’t have this problem. Anyways, try changing the wire and tell us what happens.

1 Like

try these things, 1) use a screwdriver or small object to press the reset button on the controller, 2) use a different cable, 3)try a different program, 4) use a different computer (if available), 5) try a different brain (if available).

Thank you . I have tried 3 different cables all to no avail. A former student came in to help and went through the entire process, checking multiple brains, cables, ports, & computers. We came to the same conclusion the pc port on both the brain and the remote have been compromised (lose, have to put pressure up or down on the cable) in order to get to be recognized by the computer.

Thanks. We have attempted these and more twice.

I have had this issue in the past. While I have no idea what caused it, it was fixed when we RMA’d the brain because of dead ports. Through our troubleshooting, it seemed like the brain was faulty.