VEXcode trouble when downloading to the Brain

Anyone have suggestion?

We can’t download to V5 Brain from any VEXcode platform from our student profiles b/c of network permissions. Specific problem is “command prompt disabled by admin” and then the download times out after 60 seconds and we are prompted to Abort the download. According to VEX Support yesterday, VEXcode communicates with the VEX server every time you download to the Brain and there is no way to even to this offline to avoid the communication problems.

VEX Support has provided instructions for our tech dept for creating permissions to work around this. However, my IT dept is apprehensive for one reason or another (I’m not totally sure of the details).

Do any of you have similar experiences with this that you have worked through with your network admin and able to provide some feedback or maybe just some details of how you were able to allow this communication to take place with minimally invasive access on the network?

A little frustrated…hoping you gurus have some good news and sound advice. :slight_smile:

Hmm, an error message reading “command prompt disabled by admin” doesn’t sound like it has much to do with network permissions…could you include a screenshot of the error you’re getting?

AFAIK, this is only true for VEXcode blocks on some platforms (iOS, Android, Chrome OS).

What specific program are you using, and on what operating system?

Have you tried using another c++ IDE? Do not quote me on this, but I believe the vex library has built-in methods to build and upload programs. If you look through the API, you will probably find them.

So, this is Greek to me. If you could water that vocab down a bit, I’ll give any feedback I can.

But for @holbrook - screenshot attached. And we are using VEXcode V5 Text with Windows 10.


That does not look like it has anything to do with network permissions.

I’ll bet that if you try to run cmd.exe on that computer, you’ll find that’s blocked as well. Blocking access to the command prompt is a reasonable security-policy thing to do in a school in most cases, but it makes it pretty much impossible to do things like compile software.

Trying to compile software in a different integrated development environment as @nmh322 suggested will likely hit the same problem.

There is probably nothing you can do other than working with your IT dept. to get around this restriction.

When I was in high school we hit similar security-policy problems trying to run ROBOTC on school computers - school IT solved it by creating a new user account with the correct permissions for use by robotics students when programming robots.

Then when I took AP comp sci, we hit similar problems with various IDEs and this time IT solved them by issuing every APCS student a laptop, for use in class only, with more lax security restrictions so that it could run the Java IDE and come other software (it was a small class in a big school, so they had enough old/extra laptops already lying around to do this).

Maybe you could work out some similar solution with your IT people.

Unfortunately, I think this is where we are heading. Just kind of stinks that it has to be so locked down that we can’t even function.

In the meantime, I wonder if VEX Support and the developers have a solution in mind that would not be so prohibitive in what is surely most school settings? Or is that just the nature of the beast with C++ compilers (if I said that right)?

That’s just the nature of the beast - it’s probably not super-practical (or a good idea) to write a compiler from scratch for something like VEXcode, let alone one that doesn’t use any command-line tools.

ur account has pc admin pri ?

Yes. Limited. But I do have some admin privileges so I can manage software in my lab.