VEXcode V5 Blocks Version 1.0.4 Release

We are happy to release version 1.0.4 of VEXcode V5 Blocks, it can be downloaded here:
https://www.vexrobotics.com/vexcode-download

New for this version:

  • (All) Implemented detailed messages when compiler errors are generated.
  • (All) Added logic to detect duplicate variable names in existing projects.
  • (All) Added logic to prevent duplicate names when creating variables/lists/devices.
  • (All) Improved variable name and device name validation to avoid using reserved words.
  • (All) Added a Controller block to programmatically enable/disable control of the Devices Window configured Controller.
  • (All) Updated existing and added new example projects.
  • (All) Add a timeout for the Cloud Compiler process to prevent the application from locking up during communication errors.
  • (ChromeOS) Improved Cloud Compiler connectivity to prevent communication errors.

Some known issues include

  • Blocks do not automatically update when device / direction names change in the Devices window
  • Recent Projects is not yet supported on ChromeOS
  • Tutorial videos cannot be played in “full screen” mode on ChromeOS
  • Using the “Share” button to generate a PDF of the project does not print the content of project notes (yellow boxes).

Just like normal, iOS and ChromeOS builds for this version may be delayed by a few days due to Apple / Google review processes. These will be published as soon as they are approved.

As always, we appreciate any user feedback. If you come across something that doesn’t seem right, please let us know below!

14 Likes

I am getting this error when VEXcode tries to update to the newest version. The current version was installed from an MSI.
vexcodeupdatebarf

2 Likes

The 1316 installer error, is an error reported by the Windows application installation system. There are several causes for this issue, but they do not occur for the vast majority of users.

Before going any further I would like to know if you have tried to restart the computer and run the installer again. It is always amazing how often a quick reboot can fix computer problems. It would also be useful to know if this is from the update feature in the VEXcode V5 Blocks app for when you download and run the installer manually.

If you have tried to restart the computer and you are still having issues, there are a few things I can recommend trying to fix this.

  1. If manually downloading, try to redownload the installer, as sometimes the installer can be corrupted during the download process. Since this is the fastest option to try, I recommend starting with this.
  2. Try to uninstall the application first. Since this can because by the operating system thinking that the same version of the application is already installed, it can sometimes be resolved by uninstalling the existing application. This will usually let Windows realize that the same version is not installed since the application is not actually installed. I know this is not ideal, but this is the next fastest and is very simple to try. If you need instructions for how to uninstall VEXcode V5 Blocks, please check the links below.
    Windows 7 Uninstall Guide
    Windows 10 Uninstall Guide
  3. If the redownload and uninstall does not work, You should contact support directly as the process will require more information about your computer setup and will need to be adjusted based on that information.
3 Likes

Thanks for the reply.

The problem occurred when the auto-updater tried to run. The installer required a reboot of the computer mid-install, and the error came after the reboot and when the installer seemed to be close to finishing. It then gave a message that the program was not installed.
I tried downloading the MSI install file and running that, but it gave a message that a previous version was installed and would need to be uninstalled first. I did not try manually downloading the .exe file.

I haven’t tried manually uninstalling the program and then reinstalling it, but I don’t have any reason to believe that wouldn’t work. I use this software with my class, so it is installed on all the student computers, and it is also is installed on all our team’s laptops.

The original install was deployed with network deployment software using the MSI install. My guess is that the install error came from the auto-updater trying to install the new version, but the old version needs to be uninstalled first and for some reason it did not handle the uninstall properly.

Beyond that, I would like to know if the update process can be streamlined and simplified, and if not, blocked. My students don’t have administrative rights on their computers, but the updater needed an administrative password I think twice, then the computer needed a reboot, then it asked for another administrator password, then failed. Even if it would have succeeded, that seems like an untenably clunky update process. Is there no way to do an in-place update without uninstalling the previous version? If not, it would be nice if the MSI install would have a switch available during install that could be used to suppress update messages. I know that there is an option to ignore the update (which is what I am telling them to do now), but many will still click on update.

4 Likes