VexIQ Utility disconnecting (MacOS, 1 ST GENERATION)


I am trying to update my first gen brains after a year out of service. If the brain connects at all it is briefly before I get a “USB connection failure.” Sometimes it will reconnect if I wait but then disconnect after a few seconds. I hope someone can help. Here are the important stats:

  • I am running MacOS Big Sur
  • I have uninstalled and reinstalled the Utility 4 times
  • I do not have any other VEX software or extensions installed
  • I have switched cords 4 times
  • I have restarted my computer 2 time
  • I have tried different brains
  • i have tried it with components connected and disconnected
  • I have searched this forum for solutions and none of the suggestions work or are for Windows

Help Please!


Welcome to the forum.
There are a few things you can try:

  1. Changing the cord (the cord may be damaged)
  2. If step 1 doesn’t work, try holding the cord at an angle in the brain USB port
  3. If neither of the previous steps work, try using a different device to update the brain.

I have two Gen 1 brains at the house and one of them is finicky with the cable. I did the same thing - switched ports, switched computers, etc. I could, sometimes, make it into Vexos only to have it drop. For that particular brain, I have to make sure I have a good quality cable or it will do the same thing you describe. And by “good quality” I really mean “superior quality”. The ones that came in the Vex kits weren’t cutting it. The one that worked came with an HTC Vive-pro.

But you’ve tried multiple cables and providing at least one of these is good - if all your disconnects seem to happen at roughly the same instance (your description suggests this is not the case but this is worth a mention), I would look into something software related dumping that USB connection. I’m not overly familiar with MacOS but I would certainly find a Windows machine, if you can, install Vexos, and see what happens.

My guess is a “bad” cable or brain port.