VEXnet 1.0 communication issues

Hello VEX forum

We are experiencing a wireless connection problem and we need your help.

The day before yesterday we successfully set up VEXnet connection and practiced. Nothing was changed since then about the robot or the program, but yesterday when we were trying to connect again, the joystick and cortex wouldn’t sync. Today the problem persists. We followed the troubleshooting flowchart, but the instruction didn’t help.

Light on Joystick:
Joystick: solid green-- fully charged batteries
Robot: no indication-- not connected
VEXnet: first slow flashing yellow, then quick flashing yellow-- Key is detected and trying to sync

Light on Cortex:
Robot: fast flashing yellow
VEXnet: fast flashing yellow

Usually we can get connected within 3 seconds after the described situation occurs. But this time the situation persists and the two won’t connect. We waited for like 5 minutes and the lights still keep flashing like described.

Our batteries are all fully charged. We are using easy c, both joystick and cortex have 3.23 firmware. We have back up battery and power expander. We are using easy c competition template, field control setting. We are sure that we paired up the joystick and the cortex. The joystick is calibrated. We are using VEXnet 1.0, the black keys.

We tried to connect the joystick to the computer and set up wireless download mode when the lights flash as described above, but it didn’t help. We tried to change to competition setting with autonomous, but it didn’t help either. We are still trying to change keys.

Today we tried to load our competition program to another cortex and connect it with a different joystick, but the problem STILL EXISTS. We tried to load easy c default code but that doesn’t seem to help.

We are at a school with school wifi, and we wonder whether that is the cause.

Please help us as we have a tournament this weekend. Thanks very much!

Hello CCA#392,

Thanks for your detailed email.
Based on your description, my first recommendation is to make sure the robot still operates in tether mode. If so, then please try to operate the robot in wireless mode in a different environment such as the School parking lot or football field.

If all of the above fail, please replace your VEXnet Keys 1.0 under the 2.0 Trade-In Program.



Thank you Eli. After two days of experiment and debugging we finally found one pair of 1.0 keys that worked with each other. We did well at the tournament.

We have already sent the majority of our old keys to trade, which is why I was almost freaking out that none of the remaining keys would work. But things turned out fine; we just received our new keys and we are trying to workous the software.

Thank you!