VEXnet 2.0 Radio Firmware Update Issue

I’ve been trying to get a connection using the new keys. I have updated both the cortex and joystick to the latest firmware using RobotC 4.08. Upon installing the VEXnet 2.0 Radio Firmware Update Utility, I get the following error: “SetupCopyOEMlnf() call failed - code - 536870353”. Trying to repair the utility results in this same error. The installation will complete, call itself successful, and the tool will show up on my desktop. I can run the tool, but it will not detect either of the two keys.

Once again, I am on Windows 8. RobotC version 4.08. Cortex and joystick are updated.


We also had the same issue, also with the exact same error. The error happens when you install the drivers, so when you try to upgrade your keys, it doesn’t have the drivers installed. This is why the keys aren’t being discovered. The way to fix this is to use a computer that doesn’t have Windows 8 installed on it.

Hahaha… -_-

Try right clicking the install file and click troubleshoot. If it doesn’t automatically detect that the program should be run in 7/XP mode, you’ll be able to do so manually.

I do not have windows 8 anywhere, so I cannot try this. I think it’s a “driver signing” issue. The installer is trying to install the .inf file that lets windows know that the VEXnet 2.0 key will be seen as a COM port. Try the instructions for booting windows with driver signing disabled explained here.


Install the firmware update utility and see if it works, then reboot with the signing turned back on.

It is indeed a driver signing issue. I had to disable driver signing enforcement to get it to work on my windows 8 computer. I actually came here to make a post about it but I see you beat me to it.

I can confirm that disabling driver signing on Windows 8 does fix this issue.

I just looked at the tutorial from the link you provided. For me, the process was a bit different. I had to go to Settings>Change PC Settings>Update and Recovery>Recovery>Advanced Startup>Restart Now

This may be because I have updated to Windows 8.1.

The latest VEXnet key update utility (>= 1.43) contains documentation (PDF) on how to install the drivers on Win8. It’s a lot of steps, but it works.

You’d think they’d spring for a signed driver…