Vexnet 2.0 Upgrade Hints

I did not have an easy time with the Vexnet 2.0 upgrade process. But a nice hour long call with Eli at Vex helped me through it!

So here are some items that he shared with me as well as some things that happened in my upgrade.

  1. I think this was the biggest culprit. I had a serial com port stuck so the Cortex was not seen by the computer in the upgrade utility. When you go in the device manager, you see the device has a yellow exclamation point in it. I uninstalled this. Simply disabling the problem com port did not work. The label would say it is a vex device but this is as close as I could find on the web.

  1. No 7.2v battery is connected when doing this Cortex upgrade. It makes hitting the config button a bit tougher as you put in the A-A cable. So bring up the Vexnet firmware upgrade utility, plug the computer end of the A-A cable in and then manage the config button as you plug in the cortex end of the a-a cable. Search goes real quick then and then the downloading.

  2. The config button is not typically needed on the joystick upgrade.

  3. Re-flash the robot C firmware once the new master firmware is loaded.

  4. Close robot C before running the Vex firmware upgrade utility

  5. Pair the joystick and cortex once the firmware is all up to date. You can now use either set of keys.

I tried loading the new master firmware files manually via robot C but it did not seem to work (prior to fixing #1 above).

I did this at work where many Wi-Fi networks are around. However neither Vexnet 1.0 nor Vexnet 2.0 were experiencing drop outs. I will test at the club with many more robots running Vexnet 1.0 Tuesday evening for drop outs and interference.

Debugger on Vexnet 1.0 keys were working as well as Vexnet code download. Of course I tired to download via the joystick and vexnet 2.0 keys at first instead of the A-A cable. Doh!

Swapping between Vexnet 1.0 and 2.0 keys worked. I tested on a manual game switch where it responded just fine. I walked 60 or so feet way and Vexnet 2.0 was still going.

The test program was just one motor in port 1 tied to a joystick so no stress on the amperage running through the cortex to see if that has any effect.

I hope this was helpful to anyone and alleviates any future Vex tech support calls.

One down, 20+ more cortexes to go (once more field testing and that Vexnet key trade in program is available that is)!

The EasyC tech support engineer made this comment in the EasyC tech forum.

I had a feeling there were some other download problems, I have been seeing more download errors as well with both ROBOTC and the open source download code I posted, however, I hadn’t really decided if it was the firmware or just me :slight_smile:

Anyone from VEX care to comment on what is happening here?

This is where a full set of release notes would help us all understand what other parts of the firmware were touched in addition to support for the new VEXnet 2.0 keys. For example, was the “runaway robot” problem that happens when the user processor crashes and leaves the motors at their previously commanded speed fixed?

Hi James,
As it was explained to me… somewhere along the line our lead programmer flipped a flag which is causing the errors. He has flipped it back, and the fixed version (4.0.1) is going through regression testing right now. This should improve the download robustness.

We will work to try to provide more detailed release notes in the future, we understand why you’d like to see them, and there is really no good excuse for why we don’t have them available.

Sorry for the inconvenience.

Thanks for the feedback, there’s been no significant inconvenience, just a few download failures, it’s not a big deal but I’m glad you have a solution.

I’ve reverted back to version 3.23, V4.0 is almost unusable with ROBOTC V3.6. I tried at least 10 times to get the ROBOTC firmware to load this evening and even then I’m not sure it was working correctly as it was behaving strangely. Now back on V3.23 and everything is happy.

V4 firmware was a little more stable when I was using ConVEX and my own download utility, it still failed about 1 in 3 tries.

I’m downloading from a Mac under parallels desktop using the prolific serial adapter and the USB A-A cable to connect cortex and joystick. This is the same configuration that I’ve used for hundreds of hours of ROBOTC and ConVEX development and has always worked well. It’s a total PITA with V4.

Anyone else experiencing these problems?

I had issues with my code running on the v4.0 firmware. On 3.23 I had no VEXnet dropouts but now what was occurring was after a few seconds I had a blinking red robot light.

Friday I’m downgrading back to 3.23.

So far we have had no issues. We have used the old keys when uploading code, and the 2.0 during competitions. The robot did seem possessed on one field we played on, but it behaved fine in another field.

Can you describe how your robot seemed possessed? Did it move randomly in ways your controller did not instruct it to? Did it continue one action infinitely until it was turned off?